[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

X startup problems (solved!)


A computer I was doing some upgrades on ceased working. I suddenly 
found that I can no longer run X as a user other than root.  If I 
use xdm, I just get kicked back to the login screen.  If I run 
startx, the X-server just shuts down with no diagnostic messages.

Unfortunatly I can't even catch the error messages
when using xdm cos they get sent to tty1 and immediatly 
disappear behind the login prompt :(  When using startx
there is nothing abnormal reported.

I did manage to see this in ~/.xsession-errors :
exclusive open for tmp_name failed in m4_defs: Permission denied

The /usr is shared between 2 computers and works fine
on one of them.  Nevertheless I tried doing a
chmod +s /usr/X11R6/bin/XF86_SVGA and even a
chmod +s /usr/X11R6/bin/xconsole to no avail.
(both currently has permissions set to -rwxr-xr-x)

Someone suggested that one could try:
rm /dev/console; mknod /dev/console c 4 0
but this made no difference.

The machine usually has /usr and /home nfs mounted.
I tried using the local copies (straight debian)
but this made no difference.  That leads me to believe
the problem is in another directory.

I have rebooted several times, so it shouldn't be a 
/tmp/.X11 problem either. (it currently has permissions
set to drwxrwxrwx)

Any other ideas ? (it must be something to do with 
permissions cos root login gives no problems !#%?!#@X)


addendum:  Just before I was about to post this message
I came across the following in DejaNews:

[the messages in the .xsession-errors]

> Ah. It's a problem with fvwm. Do you have strange permissions set on 
> /tmp? /tmp should be owned by root.root, with mode 1777 (drwxrwxrwt).

Yes thats the solution.  The permissions were set wrong for /tmp 

Phew !!!!

People have reported that this is caused by the base-1.1.0-13.deb
but I have base-1.1.0-14.deb on 2 computers and only 1 of them 
caused these problems.  Could it be due to an unclean shutdown?

ps: CC any replies to j.sigbrandt@elec.gla.ac.uk since I'm not on the list

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-REQUEST@lists.debian.org . Trouble? e-mail to Bruce@Pixar.com

Reply to: