[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: problems with X

On Sat, 5 Oct 1996, Stephen Early wrote:

> In article <[🔎] Pine.SOL.3.95.961003222706.18895A-100000@striper> you write:
> >I have installed Debian 1.1.9 and xbase, xlib, xserver-svga, and fvwm
> >packages. I chose during xbase to use xdm to start x.. and during boot-up
> >I see the message "starting xdm".. however typing "xdm" at a root prompt
> >doesn't do anything. I tried xinit and got the following output:
> If you use xdm to start an X server, then the server should start
> automatically when you boot. If it doesn't then there's something
> wrong. You shouldn't have to type 'xdm' at any prompt.
> >TRANS(SocketUNIXConnect) () can't connect: errno = 111
> >giving up.
> >xinit:  Connection refused (errno 111):  unable to connect to X server
> >xinit:  No such process (errno 3):  Server error.
> This is the clue. For some reason, the X server is unable to create
> the Unix-domain socket to listen for local connections. This could be
> because you don't have Unix-domain sockets in your kernel (I don't
> know whether this is a configuration option anymore) or because there
> is something up with the /tmp/.X11-unix directory.
> Try deleting /tmp/.X11-unix (and everything under it) and starting the
> server.

My /tmp directory was empty.

I should point out that the output above is what I get when I type "xinit"
at a root prompt. typing "X" gives me a seg. fault, and "xdm" does

Additional: I added the 75dpi, 100dpi, and PEX fonts in addition to
fntbase -- I still get the above errors (the font messages have largely
disappeared though).

Please, someone help me start X!!


Chris R. Martin              email: chrism@asic.sc.ti.com
			     www: http://http.tamu.edu:8000/~crm7479

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-REQUEST@lists.debian.org . Trouble? e-mail to Bruce@Pixar.com

Reply to: