[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: My experiences of the installation

On Mon, 20 May 1996, Esa Turtiainen wrote:

> to get my favorite Emacs keys to work. Isn't there any easier method
> to get all the meta characters to work?  ^] should be still added to
> get easily the Telnet quit character. But really, they should all be
> there.

Agreed, the Meta keys for Emacs should be in the keymap files distributed
with Debian... They just aren't right now. What you can do, though, is copy
your keymap file to another one and then modify that to your liking and
have it loaded by default at boot. Not very hard.

> HOWTO/Finnish suggest
> 	LC_CTYPE=finnish.iso88591
> All the perl programs give a three-line warning after that. 

Debian doesn't have the locale support files. So basically perl is
complaining that it can't find the files that describe finish.iso88591. I
hope to fix that by making a 'locale' package at some point in the future.

Some other Howto's or mini-Howto's have interesting things to say about
keymaps and 8-bit character set support... You might want to browse in
/usr/doc/HOWTO some more (assuming you installed the howto package).

> 8-bit modes
> -----------
> There are good hints in HOWTO/Finnish how to make less, emacs, etc. 
> to work with 8-bit characters. Too elaborous.
> Xterm seems to filter all the alt-commands to some 8-bit characters.
> No Emacs-editing is possible. Rxvt seems to work, though.

For xterm, try adding the following to your /etc/X11/Xresources file (or

XTerm*eightBitInput:    false
XTerm*eightBitOutput:   true

> I accidentally loaded NAS and it made something that did not
> work at all. 

Then try purging it (using the '_' key in dselect).

> One important thing is to remember
> 	depmod -a
> after installation (make modules_install). Debian does not do this
> in every boot like the system I used to have.

The default behavior is to run 'depmod -a' every time you boot into a
kernel with new version. If you don't like, go edit /etc/init.d/modules. By
uncommenting three lines you can have 'depmod -a' run every time you boot.

> I think that the system should find sbpcd using driver name like
> eth0 but it can not (BUG?).

Huh? eth0? That's for network cards.

> It is a good idea to add the following lines to /etc/fstab
> (they could be there already):
> /dev/fd0		/floppy		auto	noauto		0	0
> /dev/sbpcd		/cdrom		iso9660	noauto,ro	0	0
> Some notes: isofs do not work as type (BUG?).  /dev/cdrom would be
> nicer to use but umount do not accept it. I does not undestand that
> /dev/cdrom is a link to /dev/sbpcd (BUG).

umount is perfectly happy with my symlinked /dev/cdrom... Try putting
/dev/cdrom instead of /dev/sbpcd in the fstab file and see if it makes your
umount happier.

> I have not bothered to install this before, seems usable.
> If it is running, you can not start X using startx, because 
> /dev/mouse is used already. If X is running, you can start
> gpm.

You can configure gpm to send a copy of the mouse events to a fifo
/dev/gpmdata. Then you point the X server to the fifo instead of the mouse
device. Look at the gpm -R option in the man page... Never tried it myself,
but you might want to give it a try. You'll probably need to create the
fifo yourself.

> I tried not to install vi, first. However, the default configuration
> of many utilities require it. I found:
> 	- crontab -e
> 	- CVS 
> So, I ended up to install it.
> At least crontab starts to work, if you set environment variable 
> EDITOR. Maybe it should be in default /etc/profile (set to what?
> hopefully not ae).

Ae is there because it's user-friendly for total newbies. Other Unix users
know enough to set EDITOR and then they never have to deal with ae.

> BTW. I used the followin one-liner 'dlocate' to find out to what
> package a file belongs:
> 	grep $1 /var/lib/dpkg/info/*.list

Try dpkg -S instead.

> Despite the help message, dpkg -L and dpkg --list are not the
> same.

You're right, but you need to look at the help message some more.

       dpkg -L|--listfiles    <package-name> ...
       dpkg -l|--list         [<package-name-pattern> ...]

> locate
> ------
> Do not work. It tries to run as nobody but because nobody do not
> have shell defined, su fails (why? it should work). I added 
> -s /bin/sh to 
> 	/etc/cron.daily/find

This is a known bug with the nobody passwd entry. Just set nobody's shell
to /bin/sh.
> Init files
> ----------
> I am little missing some menu-based interface to init-files. /etc/init.d
> should have just files that are linked to different rc.* files. Now there
> are additionally some files that are really support files for inittab.
> If you make modifications to files in rc.[1-6], it is unlikely that
> you make them in all 6. This makes levels 2-5 really unusable.

Files? You meant symlinks, right? The rc.[1-6] directories should only have
symlinks. Unusable? The point of having four different multi-user runlevels
is so people can customize what happens in each. If you intend to play with
/etc/rc.[1-6] a lot (unlike most people :-) then have a look at the manpage
for update-rc.d

> I am planning to study how to make a Debian package by making ssh
> package (http://cs.hut.fi/ssh). If this goes OK, I could consider 
> Harvest cahce if no one has done that.

Ssh is already packaged (by me)... I just have to resolve the fun legal
issues encryption seems to give rise to.  But it should be out soon, I
promise. So unless you like reinventing the whell...

Harvest? Don't know if that one's taken. The're a regular posting that
describes the packages that are 'taken' and the ones that Debian
needs... You'll want to have a look at that. I *think* it's posted to
debian-user every so often... It's also... err... somewhere on the web site
(http://www.debian.org/), in the mailing-lists archives at the very least.

Welcome aboard...


Reply to: