[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

My experiences of the installation

I send here some notes of by beta test installation. Everything
works, I have just couple packages left that I don't really know
(dselect don't either) if they are installed or not.

	Esa Turtiainen

Some notes of my Debian installation

	Esa Turtiainen

Because my old a.out Linux is totally outdated, I decided
to make a new installation from scracth. I selected Debian
because some years ago I worked with Sys V packages. I noticed
that they are a nice concept but to be usable the whole Unix
should be rewritten. Now it seems that someone is trying to do

I did this to my home computer. I started at saturday (May, 11)
and on tuesday everything mostly worked including

- ppp connection
- X
- keyboard (always a problem...)
- sound
- mirroring
- httpd (and old WN pages and scripts converted to Apache)
- Harvest cache (not a part of debian, shame)
- SSH (the same)
- Netscape
- ... and all the nice utilities I have used to in Linux

I document here some of the problems I found. Mostly they were
not serious and likely not bugs as well. A common problem is
that I should re-install to find out afterwards to find out what 
was the truth.

So, this deals with Debian 1.1 beta, snapshot taken about May, 11th.


After booting the new system the keyboard was not right. I had
selected the Finnish keyboard but the layout was still American.
Luckily I know it quite well, just close the eyes.

I tried many things. Likely the problem disappeared after I
re-installed the kbd package and rebooted.

Could it be that the /etc/rc.boot/0console was not executable in the
system from floppies? That is the place where it is set. (I have to 
admit that I did not found it before the problem was solved.)

A lesser problem is that the map file for Finnish keyboar is not 
complete. It is not very nice for coding because ', `, ~ and ^ are
dead characters for composite characters. There is a fix for this 
in HOWTO/Finnish and it is just cosmetical for coders. Worse problem
for me is that Emacs control characters are not there. I had to add 
the following addition to /etc/rc.boot/0console:

loadkeys << '@loadkeys'
        alt     shift   keycode 6 = Meta_percent
        shift control keycode  53 = Control_underscore
        alt             keycode 86 = Meta_less
        alt     shift   keycode 86 = Meta_greater
        alt     altgr   keycode 86 = Meta_bar

to get my favorite Emacs keys to work. Isn't there any easier method
to get all the meta characters to work?  ^] should be still added to
get easily the Telnet quit character. But really, they should all be

HOWTO/Finnish suggest


All the perl programs give a three-line warning after that. 

8-bit modes

There are good hints in HOWTO/Finnish how to make less, emacs, etc. 
to work with 8-bit characters. Too elaborous.

Xterm seems to filter all the alt-commands to some 8-bit characters.
No Emacs-editing is possible. Rxvt seems to work, though.


It was a big job to get the sound working. This was due to new 
kernel modules that I did not quite understood.

Most available configuration files speak of the dynamic module
loading with kerneld. However, it seems that the default kernel
don't support that. Therefore, the modules should be added to 
/etc/modules. However, I did not do that like it. I compiled a new
kernel that used loadable modules.

Main reason to compile a new kernel was to get sound configuration 
right. I suspect that the default configuration used default
SoundBlaster configuration that is for some reason wrong to my
SoundBlaster 16V.

	Low DMA 1, High DMA 5, IRQ 5

It seems that you have to understand modules quite well to do an
advanced installation (like any using sound). There could be a little
more help for this.  It took many days to believe that
HOWTO/mini/Modules is a good file to read.

I accidentally loaded NAS and it made something that did not
work at all. 

Kernel sources

One file got installed to a wrong place in 'make
modules'. misc/sound.o got installed to /usr/src/linux/modules/misc,
not to /usr/src/linux-1.3.64 that is a totally different place. Easy
fix is to create directory modules to /usr/src/linux and copy the
result to the right place.

One important thing is to remember

	depmod -a

after installation (make modules_install). Debian does not do this
in every boot like the system I used to have.


For my Old Panasonic CD-ROM it is better to add the following option
to file /etc/conf.modules:

alias block-major-25 sbpcd
options sbpcd sbpcd=0x300,0

It is still very slow to load this driver but essentially faster than

I think that the system should find sbpcd using driver name like
eth0 but it can not (BUG?).

It is a good idea to add the following lines to /etc/fstab
(they could be there already):

/dev/fd0		/floppy		auto	noauto		0	0
/dev/sbpcd		/cdrom		iso9660	noauto,ro	0	0

Some notes: isofs do not work as type (BUG?).  /dev/cdrom would be
nicer to use but umount do not accept it. I does not undestand that
/dev/cdrom is a link to /dev/sbpcd (BUG).


At some point ae stopped totally working. Keyboard gives quite random
responses and there is no way to get out.

If I write FooBar, then after first return character, it writes:


This happened about the same time than I got the keyboad to 
work. At one time, this was the only editor I had. The only
editor should be a little more reliable.


Emacs had an interesting feature not to work when network
was down. It turned out that it requires that the hostname
is in /etc/hosts. It finds out the machine name and asks
it from name resolver.

In my installation I first said that the name of my machine is
turtiainen. Later I noticed that it is used in many places where the
full name is used. I changed the name to turtiainen.dna.fi
but it is impossible to find all the places where it should 
still be changed. /etc/hosts was a place where it was wrong, 
still just turtiainen.

It causes very difficult problems if you do not put domain name
to the machine name in installation... (NEEDS BETTER WARNING)


I have not bothered to install this before, seems usable.
If it is running, you can not start X using startx, because 
/dev/mouse is used already. If X is running, you can start


I tried not to install vi, first. However, the default configuration
of many utilities require it. I found:

	- crontab -e
	- CVS 

So, I ended up to install it.

At least crontab starts to work, if you set environment variable 
EDITOR. Maybe it should be in default /etc/profile (set to what?
hopefully not ae).


In my machine the only network is ppp. Therefore it is strange that 
pppd is started after many other network utilities. I changed the
filename in /etc/rc2.d

	S20ppp -> S13ppp

My ppp is in /dev/cua3. It took long time to find out that the
system has commented out the setserial for this cua (due to
incompatibility with some hardware). So, when ppp was started, 
the system got wrong interrupts. After that, old options worked
fine. Look:



Is still a little confusing tool to use. Still some more work
needed to get the user interface nicer.

I managed to get the system to imagine that something is installed
although it was not. It is quite difficult to find out.

It should be easier to re-install a software to reload all 
configuration options.

BTW. I used the followin one-liner 'dlocate' to find out to what
package a file belongs:

	grep $1 /var/lib/dpkg/info/*.list

Despite the help message, dpkg -L and dpkg --list are not the

Before getting the keyboard right it is not possible to get from my
keyboard character \. This is the search again character in


A fantastic tool to get debian sources. The tool is easy (too easy?)
but mirror master concept confuses the configuration.

Manual page refers to program mm, but the installed name is

Some problems in dependencies

I tried to install sendmail but there is some dependency problem.
biff, mailx and elm require mail-transport-agent that is provided
by smail but not by sendmail.

tcl vs. tcl-dev has some serious problems.

I suspect that many packages forget to make ldconfig (X11, psutils).


Do not work. It tries to run as nobody but because nobody do not
have shell defined, su fails (why? it should work). I added 
-s /bin/sh to 



The examples in cgi-bin are not very nice. At least one of them
has wrong address to perl in #!/. Just test-cgi and maybe calendar
should be left here, others should go to /usr/doc/examples/apache.

I guess that the /var/web/webspace should be owned by group www-data
because this exists in the /etc/group.


Works but the installation is always little confusing. There was
no specific problems however.


Did not work because I gave the host name without domain. This caused
that all the incoming SMTP mail went to some kind of loop and ended to
error directory.

After re-installation it works. I still have some problems with
procmail, I think that the .forward should be somehow different.

Dial-in line

My brother sometimes dials in to use my fixed Internet connection.
The configuration is not difficult but still there were some problems.

I naturally use mgetty for dialin lines. There is one problem. I do
not want to keep the modem on all the time. If I shut the modem down,
mgetty fails and gives one init log message per about one minute and
one message to it's own log in difficult-to-find place
/var/log/mgetty. In my previous installation I once found 40MB log
from my system.

I created a run lever 3 for mgetty-on state.

	# Answer to telephone on runlevel 3
	d2:3:respawn:/sbin/mgetty -n 1 ttyS1

First, my configuration for fixed Internet line was in file /etc/ppp/
options. I thought that the options in ~ppp/.ppprc or
/etc/ppp/options.ttyS1 would overwrite these option. No such luck.

I had to rename /etc/ppp/options to /etc/ppp/options.cua3 and leave 
empty /etc/ppp/options (required) to get these conflicting options to work.

The /etc/init.d/ppp start script works just for the default ppp line
that is described in /etc/ppp/options. If that file is empty like
requred here, startup scrips starts ppp communciation on
console. Startup script must specify which ppp to start. I added the
parameter cua3 to the end of start line:

      start-stop-daemon --start --verbose --exec /usr/sbin/pppd -- cua3

Note the '--' to separate arguments.

The BUG in the system seems to be in file permissions. I tried to
add the following user to the system:


But this does not work because no ordinary user has right to access
/etc/ppp/options. After I arranged this:

	pppd[257]: ioctl(PPPIOCGUNIT): Operation not permitted

So, pppd should be a suid program. I ended up giving ppp user uid 0.
Are there any security problems with this?

Virtual terminals

First time I found the utility 'open' to open virtual screens without
password. I think that that the default configuration should be such
that F1-F4 are normal virtual terminals with gettys and F5-F11 should
be available for open. All console messages should be forwarded to
F12. The procedure is exactly what is suggested in HOWTO.

/dev/tty..12 should be in default installation as well to support
all the function keys.

It is a little unclear how to arrange permissions. Everyone must have
read/write access to /dev/tty* to get open to work.

(BTW. BUG: There are two groups 'proxy' in /etc/groups)

Init files

I am little missing some menu-based interface to init-files. /etc/init.d
should have just files that are linked to different rc.* files. Now there
are additionally some files that are really support files for inittab.

If you make modifications to files in rc.[1-6], it is unlikely that
you make them in all 6. This makes levels 2-5 really unusable.

I made three one line support scripts for init files to start and stop
these facilities:

fstart: /etc/init.d/$1 start
fstop: /etc/init.d/$1 stop
frestart: /etc/init.d/$1 stop; /etc/init.d/$1 start

Although they are trivial I have found them very useful, for example

	fstop gpm (to start X)
	fstop cached (to stop WWW cache to save memory)
	frestart httpd (to reload configuration)


I am planning to study how to make a Debian package by making ssh
package (http://cs.hut.fi/ssh). If this goes OK, I could consider 
Harvest cahce if no one has done that.

Reply to: