[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Adaptec AHA 1542 using port 130


I'm installing .96R6 (with the alternate boot disk) from scratch and
I'm having trouble getting my Adaptec AHA 1542 SCSI card recognized
with the boot disk created in the installation process.

Since my card uses port (interupt?) 0x130, the SCSI HOWTO tells me that
if it's not on port 330 or 334 I need to specify "aha1542=0x130" at the
boot: prompt.  That works just fine with the initial boot disk (which
gives me a boot: prompt) and allows me to partition and format
/dev/sda.  The boot disk created in the installation process never
gives a boot prompt and hence I don't get the chance to specify port
130.  It just boots up, fails to find the host adapter and fsck fails.

I poked around the limited filesystem looking for someplace I could
specify the port for the card - no luck.  Finaly I tried removing the
/dev/sda line from /etc/fstab (cat is *not* my editor of choice! :).
On boot up fsck succeeds but once I log in as root an infinite loop of
error messages scroll by.  Something about password failure.  (Sorry I
can't remember more about this last problem but I hoping (somehow) it's
a symptom of the SCSI host adapter problem.)

I see a couple of possible solutions to this:

1) Get the card to use port 330 or 340.  I tried this but not having
any documentation on the card itself, makes this difficult.  After
about an hour of flipping dip switches and power-cycling the farthest I
get is a "Host Adapter not found!" in the card's setup program after
hitting <cntl>-a at boot up and trying to select port 330 or 334.
Anybody know (or where I can learn) about jumper and/or dip switch
setting on this card?

2) Somehow get the kernel on the installation-created boot disk to use
port 130 for my card.  I plan on evetually using lilo but that comes
later... so there's no /etc/lilo.conf yet.

3) Use the new 1.1 disks.  I plan on doing this soon anyway. I just
thought I'd try "working through" a base installation with what was
avaliable.  Will I still be faced with the same problem though?

System info:
486-33DX, 20M Ram
ISA bus
2 IDE drives: 124M & 330M
1 Adaptec AHA 1540CF/1542CF BIOS v2.01 SCSI host adapter
1 IBM 958M SCSI drive
Trident video card 1M
(As of last night, running Linux kernel 1.1.8, 2-year-old slackware

Many Thanks,

// Keith Beattie                  Lawrence Berkeley Laboratory (LBL) \\
// SFSU Grad Student   Imaging and Distributed Computing Group (ITG) \\
// KSBeattie@lbl.gov                 http://www-itg.lbl.gov/~beattie \\
// 1 Cyclotron Rd.  MS: 50B-2239  Berkeley, CA 94720  (510) 486-6692 \\

Reply to: