[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Still can't mount CD-ROM

I recently installed Debian GNU/Linux 0.93 Release 5.  I included modules
for iso9660, msdos, nfs and sysv file systems.  My two IDE hard drives
are autodetected and included in the fstab.  But my ATAPI CDROM isn't.
When I try:

mount -t iso9660 /dev/hd1a /cdrom

I get:

/dev/hd1a is not a block device

I posted this problem to this list yesterday and received a suggestion to

mount -t iso9660 /dev/hdc /cdrom

so I tried it.  Same result.  I also reinstalled twice, adding
"linux hd1a=cdrom" at the "boot:" prompt once and "linux hdc=cdrom" once.
Same story.

I've tried installing Slackware 2.2 on my system and it does the same thing,
except that I get a "/dev/hd1a not block device" message among all the other
boot messages.  That's why I think my CDROM would be recognized as /dev/hd1a.
I found out that although Slackware includes ATAPI CDROM support in the
boot/root images that are written to disk, they don't include that same
support in the kernel they write to your bootable floppy.  You must recompile
the kernel in order to add that support.

Unfortunately my memory is too unstable to hold up through a complete kernel
compile.  So I hoped the support would either be included automatically
with Debian or would be available as a separate module that could be
compiled separately.  I haven't seen any indication as to what the case may
be yet.

Any suggestions, including requests for more info greatly appreciated.



Reply to: