[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: libX11.a in 0.93?

> I'm struggling to compile a bunch of different things,
> including Tcl 7.4 and Tk 4.0,  as well as Python 1.3,
> because I don't have libX11.a in /usr/X11R6/lib.  Did
> I mess up my installation?  Is this supposed to be there?

libX11.a will only be there if you've installed the xslib package. You 
should really be linking with libX11.sa, which is in the xstd package.

> There is a liboldX.a - should I symlink that to libX11.a?


> Lastly,  most of these programs don't seem to include
> /usr/X11R6/lib by default  (they are generally GNU autoconf
> applications,  so I'm surprised).  Why is this?

Er, because. I'll look into it.

Steve Early

Reply to: