[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

installation trouble: RAM and swap?

   I have been having problems installing debian on my laptop.
It's a compaq 486 with 4 MB of RAM.

   The first time I tried to install debian using custom mode, the steps
up to and including creation of a boot disk seemed to go correctly.
However, when I tried to boot the system (I think this is option 9
on the menu), I got a bunch of ``out of memory'' messages.

   Somebody suggested that, before booting the system, I edit
/root/etc/init.d/boot to put swapon -a near the beginning of the file.
(using the ``run a shell'' option on the menu).

   After doing this, the system does boot and allow me to log in as
root.  However, the system runs VERY slowly and often prints the message
"fork: try again."  An adduser command causes the machine to sit for
at least ten minutes with no obvious result.

   I currently have a swap partition with about 15 megabytes.  Somebody
suggested the problem may be caused by ``shadow ROM'' taking up my
RAM.  I tried putting device:himemsys /shadowrom:off in my DOS config.sys
file and booting that before installing Debian, but that didn't seem to

   Thanks for any further help.

Charles Blair

Reply to: