[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 0.93R6: pppd gives "block on freelist isn't free" system errors

Dan Halbert wrote:
> I'm having the following problem with PPP: I can connect and ping, but
> when I use ftp or telnet, I get "block on freelist isn't free: ..."
> errors in /var/adm/messages.

I had the same experience several weeks ago when trying to connect to the
Xyplex terminal service at my office. I am now connecting through Netcom
with the same kernel and ppp software without any problems.

When using Trumpet for Windows, I had no trouble connecting to the Xyplex.
I believe this is a bug in the linux ppp software, but I haven't reported
it yet. I want to get some more information from our sysadmins at work, but
I haven't gotten around to it yet.

> I did some dejanews archive searching on this, and found others with
> similar complaints, but no clear solution. Any insights or similar
> experiences? An initial attempt to rebuild the kernel generated some
> compiler warnings in ppp-specific files.

I rebuilt the kernel and the ppp software many different ways. I tried
1.3.30 kernel and ppp-2.2.0c from sunsite. None of this worked. I assumed
that there was something wrong with my machine until I successfully
connected to Netcom. I even ran with memory disabled in the region that the
block on freelist wasn't free! It just moved, of course.

We need to get this discussion going on comp.os.linux.networking and/or
comp.protocols.ppp. I would cross-post this, but I think we should include
more details from our experiences. Terminal server types, versions, modems
should be included.

Does anyone know of a linux-ppp mailing list?

Jeff Ebert

PS: Dan, I would like to know about the dejanews archive search. Please
send me private mail about this.

Reply to: