[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

CD-ROM problems and "mount" error message problem

    I am having a problem accessing my Mitsumi CD-ROM.  I tried using the
Debian boot disk with Linux 1.2.xx on it and it didn't find this ATAPI
drive.  I need a newer kernel I surmised.  So then I tried the new Linux
1.3.30 Debian boot disk that I read about in this list and as it boots I
can see that it does indeed find the CD-ROM drive (and calls it /dev/hdb).
The problem is I can't mount the drive since (according to
/proc/filesystems) "iso9660" is not a supported filesystem type.  Next I
created a custom boot disk from this distribution because that kernel does
support "iso9660" (according to /proc/filesystems again).  Unfortunately
when I boot from the custom boot disk the CD-ROM isn't found so I can't
mount it.  Either it's found and not mountable, or mountable but not found.
Am I doing something wrong?  It seems that the kernel on the Debian boot
disk can find my drive but doesn't know how to mount it, but the custom
disk that is created uses a different kernel that doesn't find my drive at

    By the way, when I tried "mount -t iso9660 /dev/hdb /cdrom" I got an
error message that says this is an unknown filesystem type and to check
/proc/filesystems, even when that file lists iso9660 as a filesystem type.
I suspect the error was actually with "/dev/hdb" since when I did "mount -t
ext2 /dev/hdb /cdrom" I got the same error message and Linux had already
mounted three ext2 filesystems for me.

    By the way, I can access my drive when booting from a Slackware disk
and I have the Linux Developers Resource toolkit 4 CD set from August 1995
available if that makes things easier.  (Unfortunately they removed the
Debian distribution from that version so I'll have to wait for the new
Debian distribution I've been reading about.)  I did manage to get version
1.2.0 of Linux into the /usr/src directory, but when I try to patch it up
to version 1.2.8 I get failed patches which seems suspicious to me.  (I was
planning on creating my own kernel with my CD-ROM driver in it, but quit
when the patching failed.)

    Thank you for any help you can give.

Emile LeBlanc

Reply to: