[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: telnet+su root->thermal process

> The quick fix is ``don't do that then'' - quit `more' by hitting `q',
> close the session by terminating bash (hit ^D or type `exit') rather
> than chopping off the telnet connection from your end.

	ahhh...that's painful to me because I'm using some very 
unreliable dialup line :( My line will be terminated at any random moment:P

> At first I thought that it was just that the rogue bash was ignoring
> SIGHUP or something; however manually SIGHUPing it (instead of closing
> the telnet connection) contradicts this.
> I've sent this message to debian-bugs as well.  It may be that the bug
> is in telnetd rather than bash, but the fact that bash starts eating
> CPU when it loses its tty is a bug in itself.

	I have also tried to simulate this on slackware,jurix,redhat. All 
of them do not have this problem. I've also tried use the bash, telnetd, 
telnet from those packages, but still got the problem :( Now, All I can 
do it ulimit -t 50.

Best Regards,

Reply to: