[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

debian 0.91 net-2 problem

I have been using various linuxes for some time now, connecting to the world
thru ethernet using the net-2 package.

I just installed debian 0.91, base only, plus net.  Installation went fine.
Setup my ethernet connection in dsetup.  Installation kernel does not support
networking so I copied in the p14 kernel I had been using (compiled under
debian 0.81), installed it using lilo, and rebooted.  This got rid of most
of the error messages during bootup and my ether card was properly detected.  

I still get the following messages during bootup:
  SIOCADDRT:  Address family not supported by protocol.
     (repeated 3 times, followed by)
  SIOCADDRT:  Network is unreachable.
This is followed by:
  Performing a few administrative tasks...
    Failed to bind string '' to function F23
    Failed to bind string '' to function F24
    Failed to bind string '' to function F25
    Failed to bind string '' to function F26

Then, I start getting the following series of 3 messages repeated at close
intervals, whether I am logged in or not (and even after shutdown):
  eth0: bogus packet size, status=0x0 nxpg=0x0 size=0x0 
  eth0: bogus packet, status=0x0 nxpg=0x0 size=0x0 
  eth0: mismatched read page pointers c vs 0
This essentially makes the system unusable for anything, and of course, I 
can't connect to anything. 

I don't know what's going on here.  In the past, when I got the "Network
is unreachable" message during bootup, it was a simple matter of the host
name, or network, or namesever not being properly set, but I've checked 
rc.inet1 and various setup files in /etc and all looks ok.  And, ifconfig
reports exactly the right values.

Anybody know what's going on here?  Do I need to load up gcc, linuxsrc, etc
and compile a new kernel under debian 0.91?  I tried the tcpip package from
slackware with exactly the same results, yet it works fine with this kernel
in the slackware installation.


Carl Powers

Reply to: