[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Actualización de paquetes stable a unstable



El Jueves, 8 de Junio de 2006 02:48, Correo de listas escribió:
> Hola
>
> Tengo un problema con la actualización de mis paquetes, estoy sobre
> una Debian Sarge y quiero pasar algunos de mis programas a versiones
> posteriors que se encuentran en SID, pero cada vez que ejecuto apt-get
> install nombre_del_paquete sale el mensaje de dependecias incumplidas.
> Por ejemplo:
>

Mezclar stable con unstable es posiblemente poco recomendable (usa 
programas de testing, que posiblemente te de menos problemas). Aunque en 
realidad, seguramente, uses los que uses te van a dar algunos 
problemillas. Mira en backports a ver si tienen los paquetes que 
necesitas.

Nota, si usas debian amd64, lo que pides es inviable. Los paquetes de 
testing y unstable se han regenerado todos. Asi, si existe el mismo paqete 
en stable y testing o unstable y lo intentas bajar, en testing y unstable 
tendra un hash diferente al de stable. apt bajara el paquete, vera que el 
hash no coincide, y lo volvera a bajar, y asi eternamente.

> marte:/# apt-get install gaim

Como has mezclado versiones? apt pining?

deberias usar apt-get -t unstable install gaim

> Leyendo lista de paquetes... Hecho
> Creando árbol de dependencias... Hecho
> No se pudieron instalar algunos paquetes. Esto puede significar que
> usted pidió una situación imposible o, si está usando la distribución
> inestable, que algunos paquetes necesarios no han sido creados o han
> sido movidos fuera de Incoming.
>
> Como sólo solicito una única operación, es extremadamente posible que el
> paquete simplemente no sea instalable y debería de rellenar un informe
> de error contra ese paquete.
> La siguiente información puede ayudar a resolver la situación:
>
> Los siguientes paquetes tienen dependencias incumplidas:
>   gaim: Depende: libgtk2.0-0 (>= 2.8.0) pero 2.6.4-3.1 va a ser
> instalado Depende: libxfixes3 pero no va a instalarse
>         Depende: libxinerama1 pero no va a instalarse
>         Depende: libxss1 pero no va a instalarse
> E: Paquetes rotos
>
> En el source.list figura lo siguiente:
>
> deb http://ftp.tiscali.de/pub/debian/debian/ stable main non-free
> contrib deb-src http://ftp.tiscali.de/pub/debian/debian/ stable main
> non-free contrib deb http://security.debian.org/ stable/updates main
> contrib non-free #Inestable
> deb http://ftp.tiscali.de/pub/debian/debian/ unstable main non-free
> contrib
>
> ¿Alguna sugerencia?
>

aparte de backports, que busques en google por apt pining


Saludos
Aritz Beraza [Rei]
-- 
Aritz Beraza Garayalde [Rei]   [http://www.ayanami.es] 
- No enviarás correos en HTML a La Lista.
- No harás top-posting, responderás siempre debajo del mail original.
- No harás Fwd, a La Lista, siempre reply.

Attachment: pgpt5bBmAHdkK.pgp
Description: PGP signature


Reply to: