[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: configurar tomcat en sarge.



El Miércoles, 12 de Abril de 2006 09:48, JeA escribió:
> Hola, necesito   y agradezco la ayuda que me puedan prestar chicos
> estoy tratando de configurar tomcat 4.1.31, para poder instalar opennms,
> he podido hacer todo pero cuando llego al punto de tomcat lo descargo y
> configuro, pero para mi debian sarge es como si no existiera porque me
> da el siguiente error
>

Ayer me pasé por los foros de ubuntu y leí auténticas burradas, así que 
preguntaré...

Tomcat lo instalaste con apt-get, aptitude o synaptic verdad?

Por lo demás, yo tengo un tomcat5 funcionando y sin problemas en debian.

>
> tortolita:/home/nms/debs# apt-get install opennms-webapp
> Leyendo lista de paquetes... Hecho
> Creando árbol de dependencias... Hecho
> No se pudieron instalar algunos paquetes. Esto puede significar que
> usted pidió una situación imposible o, si está usando la distribución
> inestable, que algunos paquetes necesarios no han sido creados o han
> sido movidos fuera de Incoming.
>
> Como sólo solicito una única operación, es extremadamente posible que el
> paquete simplemente no sea instalable y debería de rellenar un informe
> de error contra ese paquete.
> La siguiente información puede ayudar a resolver la situación:
>
> Los siguientes paquetes tienen dependencias incumplidas:
>   opennms-webapp: Depende: tomcat4 (>= 4.1.18) pero no es instalable
> E: Paquetes rotos
> tortolita:/home/nms/debs#
>

Si _no_ lo instalaste usando apt-get... esto es normal. El sistema de 
paquetes no sabe que ese programa está.

Si lo instalaste por apt, posiblemente sea una de las causas que te 
mencionaron en el otro mail. Cuando envíes dudas, es importante decir que 
versión de Debian usas (unstable, testing, stable, old-stable) o por su 
nombre (sid, etch, sarge, woody).

> No se si lo mejor sea decirle a debian donde esta instalado el tomcat,
> que lo tengo en esta ruta:
> /home/nms/otros/tomcat-4.1.31
> pero no tengo idea de donde puedo configurarselo a debian para que sepa
> que si existe y que esta configurado, llevo 3 dias en esto y estoy muy
> desilucionado...
>

man dpkg, en especial la opción --force-all.

Si _no_ instalaste tomcat usando apt-get o similares, deberías crear un 
paquete "falso" con el nombre tomcat4 e instalarlo. Hay un programa para 
hacer esto de forma rápida y fácil, pero ahora no recuerdo el nombre. Una 
búsqueda o dos con apt-cache search deberían ser suficientes, sino, 
google.

Saludos
Aritz Beraza [Rei]
-- 
Aritz Beraza Garayalde [Rei]   [http://www.ayanami.es] 
- No enviarás correos en HTML a La Lista.
- No harás top-posting, responderás siempre debajo del mail original.
- No harás Fwd, a La Lista, siempre reply.

Attachment: pgpWUVRhQBJOL.pgp
Description: PGP signature


Reply to: