[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Ayuda con Kernel 2.6.14



2005/11/12, mario <debian@estilorural.com>:
> El sáb, 12-11-2005 a las 01:56 +0100, Alejandro Garrido Mota escribió:
> > Hola lista les escribo porque estoy teniendo un serio problema que ya
> > me tiene arto y no se como solucionarlo.
> > Tenia el kernel  2.6.8-2 y se me instaló el paquete udev por lo que me
> > empezo a funcionar mal la máquina (no funciona ambiente gráfico ni
> > nada) por lo que estoy trabajando en pura consola y me tiene algo
> > disgustado.
> > Me baje hace 4 días los fuentes del kernel 2.6.14 y lo instalé a la
> > manera Debian es decir miren los pasos:
> > - Descomprimí el tar-gz
> > - Copié el config del 2.6.8-2 al nuevo directorio del kernel y lo
> > cargue todo bien es decir no debo de tener problemas porque no cambié
> > nada esta igual que el kernel anterior
> > -  make-kpkg clean && make-kpkg --initrd kernel-image modules_image
> > --revision="11-11-05"
> >
> > Perfecto todo pero dura mucho tiempo. En fin ese no es el problema
> > luego de que pasa esto y se crea el paquete .deb me dedico a
> > instalarlo es decir dpkg -i ../kernel-image<TAB>.....
> >
> > aquí es cuando biene el error, es decir me da sus buenos errores me dice:
> > " You are attempting to install an initrd kernel image (version
> > 2.6.14) while running a kernel of version 2.6.8-2, but
> > you have no suitable ramdisk generation tool installed among
> > /usr/sbin/mkinitrd /usr/sbin/mkinitrd.yaird /usr/sbin/mkinitramfs.  This will
> > break the installation, unless a
> > suitable ramdisk generation tool is also being installed right
> > now.
> >
> > Could not find . at /var/lib/dpkg/tmp.ci/preinst line 228.
> > Setting up kernel-image-...... (.........) ...
> > Failed to find suitable ramdisk generation tool for kernel version
> > dpkg: error processing linux-image-2.6.14-rc5-powerpc (--configure):
> > subprocess post-installation script returned error exit status 2
> > "
>
> Si usas testing te recominedo que instales make-kpkg de sid así como
> también el paquete yaird que es el que genera los initramfs y las
> dependencias necesarias.
>
> Segun el campo depends del linux-image-2.6.14-1-k7 necesitas:
>
> Depends: yaird | initramfs-tools | linux-initramfs-tool,
> module-init-tools (>= 0.9.13)
>
> El método de cramfs para los initrd ya no se usa a partir del 2.6.14.
>
>
> >
> > No se que hacer en verdad no se porque me da este erro me di cuenta
> > que si se instalan los modulos porque ucando hago ls en /lib/modules
> > hay una caprte del 2.6.14.
> >
> > Señores ya se que tengo instalado los paquetes initrd-tools, linux-initrd-tools.
> > Alguna sugerencia y ayuda? Definitivamente hago esto porque no puedo
> > hacer nada en ambiente gráfico ese udev me fregó la paciencia
> > --
> > Salu2
> > Atentamente:
> > Alejandro Garrido Mota
> > Edad:  16 Años
> > GNU/Linux Debian Etch
> > En kernel 2.6.11.7
> > Usuario Linux registrado #386758
> > Caracas-Venezuela
> >
>
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.2 (GNU/Linux)
>
> iD8DBQBDddbHfHuNLH93QfsRAsAXAKDKp3MTf4dq6H/TWmeWNLprtItT8gCgr95L
> OZmGENX7d3ozMTbqiP3zbOo=
> =EYr6
> -----END PGP SIGNATURE-----
>
>
>

Ok me puedes por favor pasar un reporsitorio offial (unestable) que
tenga yaird | initramfs-tools | linux-initramfs-tool,
module-init-tools ?
--
Salu2
Atentamente:
Alejandro Garrido Mota
Edad:  16 Años
GNU/Linux Debian Etch
En kernel 2.6.11.7
Usuario Linux registrado #386758
Caracas-Venezuela



Reply to: