[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

cosas raras con perl y windows



Hola:
Os cuento una cosa que no entiendo porque me pasa por si alguien le ha
pasado alguna vez:
Vamos a ver:
He copiado un script de perl desde un windows2000 con un editor de codigo
que se llama EditPlus.
Lo que hago es que lo guardo el fichero en una maquina linux directamente
por samba a un directorio donde tengo compartido con el servidor win2000.
El script de ejemplo (cuidado es muy complicado) es el siguiente:

#!/usr/bin/perl
print "Hello, World...\n";

La cosa es la siguiente.
Cuando guardo el fichero se guarda con los siguientes permisos:

-rwxr--r--    1 juak     juak           49 2002-12-07 15:49 hello.pl*
(En teoria me imagino que se puede ejecutar ya que tiene permiso de
ejecuccion no?)

intento ejecutar el script directamente y me pasa lo siguiente:

juak@KEIKO:/home/guardados$ ./hello.pl
: bad interpreter: No existe el fichero o el directorio

?????????

ahora: si lo ejecuto con:

juak@KEIKO:/home/guardados$ perl hello.pl
Hello, World...

Funciona perfectamente ??????????????????

No tengo ni idea que es lo que puede pasar, me imagino o pienso que puede
ser  que sea porque el fichero esta creado con un editor windows porque he
probado que si escribo el mismo script con el vim me deja ejecutarlo sin
problemas

¿que es loque realmente esta pasando??
Se podria arreglar?

Pos nada muchas gracias a todos :))

A ver si alguien me puede contestar poruqe ya es por curiosidad jejejejej
Saludines



Reply to: