[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Falha ao instalar libreoffice no debian sid (dependências não encontradas)



Bom,

eu pesquisei um pouco mais agora a noite, com mais tempo, sobre este problema das dependências. O problema é que o libstc++6 (v 5.2.1) está quebrando vários pacotes. Dentre eles o libboost-date-time1.55.0, que é dependência da instalação do libreoffice - apesar do default no debian ser o libboost-date-time1.58. Acho que o ideal seria atualizar o libreoffice para depender da versão nova.
Mas, aparentemente só eu estou tendo este problema, pois não tem nenhum bug deste tipo reportado.

Alguém sabe como contornar isso?

Obrigado,
Dennis

Em 3 de agosto de 2015 14:42, Dennis Gonçalves <camaradadennis@gmail.com> escreveu:
Olá a todos,

esta é minha primeira postagem nesta lista, apesar de ser um usuário de debian há quase 8 anos.

Meu problema é o seguinte: tenho uma instalação sid com plasma 5 no meu desktop (amd64). Apesar dos problemas que tem sido relatados na transição do KDE 4 para o plasma 5, eu tenho usado o plasma há umas duas semanas com tudo funcionando direitinho. Acabei tendo que instalar alguns pacotes da experimental, mas não vejo nenhum bug até agora.

Só que hoje fui atualizar o sistema com apt-get upgrade + apt-get dist-upgrade. este último comando instalou o gcc 5 sobre o 4.9 e acusou a necessidade de remover os pacotes do libreoffice (e mais alguns do muon e akonadi).

Deixei rolar, pensando em instalar o libreoffice depois (os outros não uso). Mas agora, quando entro apt-get install libreoffice, o output é o seguinte:


# apt-get install libreoffice
Lendo listas de pacotes... Pronto
Construindo árvore de dependências        
Lendo informação de estado... Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
libreoffice : Depende: libreoffice-base mas não será instalado
              Depende: libreoffice-calc mas não será instalado
              Depende: libreoffice-core (= 1:5.0.0~rc5-1) mas não será instalado
              Depende: libreoffice-draw mas não será instalado
              Depende: libreoffice-impress mas não será instalado
              Depende: libreoffice-math mas não será instalado
              Depende: libreoffice-report-builder-bin mas não será instalado
              Depende: libreoffice-writer mas não será instalado
              Depende: libreoffice-avmedia-backend-gstreamer mas não será instalado ou
                       libreoffice-avmedia-backend-vlc mas não será instalado
              Depende: python3-uno (>= 4.4.0~beta2) mas não será instalado
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.


Procurei em bug reports e em várias listas do debian, mas não achei nenhuma referência a isto. Alguém tem alguma ideia?

Obrigado,
Dennis

ps: se precisar de mais informações podem pedir.
ps2: não sei se o problema é o gcc e também não acho que seja o plasma, só citei para referência...

--


JORNAL BRASIL DE FATO
Uma visão Popular do Brasil e do Mundo
EDITORA EXPRESSÃO POPULAR
Livros bons, de boa qualidade e a preço de custo
http://www.expressaopopular.com.br




--


JORNAL BRASIL DE FATO
Uma visão Popular do Brasil e do Mundo
assine! http://www.brasildefato.com.br
EDITORA EXPRESSÃO POPULAR
Livros bons, de boa qualidade e a preço de custo
http://www.expressaopopular.com.br


Reply to: