[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Upgrade-Problem PostgreSQL



Hallo Liste,

der Urlaub ist vorbei und schon fangen die kleinen Problemchen wieder an :-/. Hier sollte eigentlich nur postgresql-7.4 und postgresql-client-7.4 aktualisiert werden, dies endet aber in folgendem Fehler:

<code>
Richte postgresql-client-7.4 ein (7.4.23-0etch1) ...
update-alternatives: Kann /usr/share/postgresql/7.4/man/man7/reindex.7.gz.dpkg-tmp nicht zu symbolischem Link auf /etc/alternatives/reindex.7.gz machen: Datei oder Verzeichnis nicht gefunden
dpkg: Fehler beim Bearbeiten von postgresql-client-7.4 (--configure):
 Unterprozess post-installation script gab den Fehlerwert 2 zurück
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von postgresql-7.4:
 postgresql-7.4 hängt ab von postgresql-client-7.4; aber:
  Paket postgresql-client-7.4 ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von postgresql-7.4 (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
Fehler traten auf beim Bearbeiten von:
 postgresql-client-7.4
 postgresql-7.4
E: Sub-process /usr/bin/dpkg returned an error code (1)
</code>

reindex.7.gz.dpkg-tmp als Ziel einer symbolischen Verknüpfung finde ich schon irgendwie komisch (Oder ist das anders herum gemeint?). Die Datei existiert natürlich nicht nur reindex.7.gz. Kennt jemand das Problem bzw. gibt es eine saubere Lösung dafür?

Bisher habe ich, zum Test, manuell die reindex.7.gz als reindex.7.gz.dpkg-tmp kopiert und auch mal den Link in /etc/alternatives/ selber angelegt, es kommt zum selben Fehler.

Bin da für alle Vorschläge offen

Gruß

Mika


--
Interested in Linux and Ubuntu? Have a look at my Blog:
http://dudleys.wordpress.com/

Reply to: