[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ATI/AMD fglrx mal wieder ...



Hallo Matthias!

Matthias Haegele wrote:
> Irgendwie hab ich was verbogen, finde den Fehler aber nicht.
> Grafikkarte ist eine ATI Radeon 9700 PRO, am AGP.
> Ich hatte das Modul mit der Standardmethode:
> m-a update
> m-a prepare
> m-a a-i fglrx
> gebaut.

Ist es denn auch für den laufenden Kernel installiert? Was sagt denn
"ls /lib/modules/`uname -r`/misc"?

> Was mich stutzig macht, vielleicht ging bei obigem auch was schief:
> 
> lsmod | grep agp
> nvidia_agp              8924  1
> agpgart                32456  1 nvidia_agp
> 
> Da sollte eigentlich fglrx stehen?

Ja.

> und das funktioniert auch nicht:
> 
>> modprobe fglrx
>> FATAL: Module fglrx not found

Kommt die Meldung nach einem Neustart oder einem "depmod -a" noch
immer? Falls ja, dann liegt fglrx.ko wohl wirklich nicht in o.g.
Verzeichnis.

[xorg.conf-Ausschnitte]

Die Ausschnitte sind relativ wertlos, wenn nicht ersichtlich ist,
ob das ServerLayout das konfigurierte Gerät auch wirklich benutzt. D.h.
in der ServerLayout-Sektion muss ein Screen angegeben sein, der als
Device "ATI Technologies Inc Radeon R300 ND [Radeon 9700 Pro]" benutzt.

[Ausgabe von dpkg -l fglrx*]

Sollte nicht auch fglrx-control (bzw. fglrx-amdcccle) installiert sein?

Außerdem scheint das Kernel-Modul wirklich nicht für den laufenden
Kernel installiert zu sein. Dein Kernel ist 2.6.22-3, installiert
ist aber nur das Modul für 2.6.18-4. Aber du könntest es ja noch am
Paketmanager vorbei installiert haben.

Schöne Grüße!
Tobias

Attachment: pgpApdrD1x7mg.pgp
Description: PGP signature


Reply to: