[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Kompilierfehler: openssl/md5.h und libcutf8.so fehlen



Am Montag, den 09.07.2007, 17:30 +0200 schrieb Agon S. Buchholz:
> Hi,
> 
> ich versuche gerade, unter "Etch" ein kleines "C"-Programm zu
> kompilieren; dabei fehlen anscheinend "openssl/md5.h" und "libcutf8.so".
> 
> Das vermisste "openssl/md5.h" bei "make" habe ich durch Installation von
>   libssl-dev wegbekommen (ich hoffe mal, dass das richtig war), zu
> "libcutf8.so" kann mir Google aber keine sachdienlichen Auskünfte
> erteilen. Auch ein "apt-cache search libcutf8" u.ä. liefert mir nichts
> Installierbares.

Kein Wunder, denn ...

> Fehlermeldung:
> 
> # make install
> install -m 755 wikix /usr/bin
> install -m 644 libcutf8.so /usr/lib
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> install: Aufruf von stat für "libcutf8.so" nicht möglich: Datei oder
> Verzeichnis nicht gefunden
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

... die libcutf8.so soll ja eben aus dem Archiuv, dass du da in der
Mangel hast, installiert werden und sollte sich damit laut Makefile in
dem Verzeichnis befinden, in dem `make install' gerade ausgeführt wird.
Im übrigen würde man nach Dateien mittels apt-file suchen, und nicht mit
apt-cache. Lies dir bitte die Befehlsbeschreibungen dieser Befehle
durch.

> make: *** [install] Fehler 1
> 
> Irgendwelche Ideen, wo ich dieses "libcutf8.so" für Etch herbekommen kann?

Ja, bauen. Und da es offenbar nicht gebaut wurde, liegt der Fehler wohl
irgendwo bei dir oder in der Quelle, die du da versuchst zu
installieren. Hast du überhaupt `make' aufgerufen? Was passiert, wenn du
explizit `make libcutf8.so' aufrufst? Das hat btw bis hierhin überhaupt
nichts mit Debian zu tun.

MfG Daniel



Reply to: