[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Probleme mit LVM



Gerhard Brauer schrieb:
Gruesse!
* Thomas Günther <thomas.guenther@gmx.de> schrieb am [30.06.06 07:23]:
[gpart]
Naja, eine Windowspartition war jetzt nicht das, was ich erwartet
habe und die Grösse mit 3MB ist auch etwas knapp.

IMHO kann man gpart doch auf direkt auf LVM-Volumes loslassen, evtl. ist
das nochmal ein Versuch wert.

Mal sehen, ob ich da noch was zu finde.


Zu den anderen Fragen:
Die Partitionstabelle habe ich nicht rumliegen.
Ich habe auch erstmal nur eine Platte im Verbund.  Was die Partition
angeht, muss man, wenn ich mich recht erinnere, eine Partition vom Typ
08E (Linux LVM) anlegen.

Wenn du noch weißt wie die Platte genutzt wurde (und bei LVM nimmt man
ja eigentlich die gesamte Kapazität) wäre nur noch die Frage: hattest du
eine primäre oder ein logisches LW? Evtl. geben ältere (Sys)Logs darüber
noch Aufschluß (hdd1 oder hdd5 bei LVM-Bootmeldungen?)

EinE Platte mit einer Partition (hdd1), mit einer VolumeGroup, einem
PhysicalVolume und einem LogicalVolume.


Dann könntest du mit fdisk einfach die Partitionstabelle wieder
eintragen.
Die Daten sind mit 99% Sicherheit noch vorhanden.
Wenn du die Möglichkeit hast mit dd eine "Sicherheitskopie" der PLatte
irgendwohin zu ziehen, dann kannst du sogar mehrere Versuche
unternehmen.

Die Sicherungskopie werde ich anlegen. Das geht leider nur übers Netz
weil lokal kein Platz mehr ist. Ein dd mit netcat sollte es ja tun,
oder? Auf jeden Fall wird sich das hinziehen. Ich meld mich dann wohl
nächste Woche wieder ...


Ansonsten wäre es wahrscheinlich schneller, daß LVM neu zu machen und
das Backup zurückzuspielen (Ja ;-) ich weiß...)

Da das bereits das zweite Mal war, dass mir das LVM abgeraucht ist,
habe ich eine andere 120GB-Platte eingebaut und ein Backup
zurückgespielt. Das Backup ist am Nachmittag vor dem Spannungsausfall
am LVM-Server angefertigt worden. Nach dem Backup sind aber vermutlich
noch Daten auf den LVM-Server kopiert worden, die aber nicht mehr
gesichert wurden, weil das nächtliche automagische Backup, was dem
manuellen Backup hätte folgen sollen, aus irgendwelchen Gründen nicht
durchgeführt wurde. Wenn es knallt, dann eben richtig.

Der Verlust der Daten dürfte sich aber in Grenzen halten, zumal die auf
dem LVM-Server gelagerten Daten ohnehin oft nur Kopien von Daten sind.
Insgesamt nicht wirklich dramatisch, aber: ICH WILL meine Daten zurück!
:-)



Sorry, daß ich dir nicht weiter helfen kann.

Es tröstet mich, dass ich nicht der einzige bin, der hier nicht weiter
weiss. ;-)

Danke trotzdem!
[...]

Gruß
	Gerhard

Gruss
Thomas



Reply to: