[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problem mit rootstrap



Hi!

Ich wollte heute auch mal ein bisschen Erfahrung mit Usermode-Linux sammeln. 
Leider bin ich nicht allzuweit gekommen.

Bereits mit der Standardkonfiguration (Die mir eigentlich ganz ordentlich 
erschien) passiert folgendes nach dem start von rootstrap:

roman@yoda:~$ rootstrap uml.img
Checking for the skas3 patch in the host...not found
Checking for /proc/mm...not found
tracing thread pid = 4104
Checking for /dev/anon on the host...Not available (open failed with errno 2)
Checking for /dev/anon on the host...Not available (open failed with errno 2)
Checking for /dev/anon on the host...Not available (open failed with errno 2)
Checking for /dev/anon on the host...Not available (open failed with errno 2)
Linux version 2.4.26-2um (root@mizar) (gcc version 3.3.4 (Debian 1:3.3.4-3)) 
#2 Fri Jul 16 17:51:17 PDT 2004
On node 0 totalpages: 8192
zone(0): 8192 pages.
zone(1): 0 pages.
zone(2): 0 pages.
Kernel command line: con0=fd:0,fd:1 con=pty root=/dev/root rootflags=/ 
rootfstype=hostfs ubd1=uml.img init=/usr/lib/rootstrap/builder devfs=mount 
rsworkdir=/home/roman
Calibrating delay loop... 930.61 BogoMIPS
Memory: 28148k available
Dentry cache hash table entries: 4096 (order: 3, 32768 bytes)
Inode cache hash table entries: 2048 (order: 2, 16384 bytes)
Mount cache hash table entries: 512 (order: 0, 4096 bytes)
Buffer cache hash table entries: 1024 (order: 0, 4096 bytes)
Page-cache hash table entries: 8192 (order: 3, 32768 bytes)
Checking for host processor cmov support...Yes
Checking for host processor xmm support...No
Checking that ptrace can change system call numbers...OK
Checking that host ptys support output SIGIO...Yes
Checking that host ptys support SIGIO on close...No, enabling workaround
POSIX conformance testing by UNIFIX
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
Starting kswapd
VFS: Disk quotas vdquot_6.5.1
Journalled Block Device driver loaded
devfs: v1.12c (20020818) Richard Gooch (rgooch@atnf.csiro.au)
devfs: boot_options: 0x1
SGI XFS with ACLs, no debug enabled
SGI XFS Quota Management subsystem
Disabling 2.6 AIO in tt mode
pty: 256 Unix98 ptys configured
RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
loop: loaded (max 8 devices)
Initializing Cryptographic API
Initializing software serial port version 1
mconsole (version 2) initialized on /home/roman/.uml/xhYNkc/mconsole
unable to open root_fs for validation
Partition check:
 ubdb: unknown partition table
Initializing stdio console driver
NET4: Linux TCP/IP 1.0 for NET4.0

###

Hier steht er dann einfach und macht nichts weiter. Der Prozess scheint 
einfach stillzustehen.

Ich hab natürlich auch schon ein wenig mit der /etc/rootstrap/rootstrap.conf 
herumgespielt, bin aber bisher zu keinem Ergebnis gekommen.

Reproduzierbar ist der Fehler hier auf zwei vollkommen unterschiedlichen 
(Hardware) Maschinen mit Debian Unstable und Testing.


Hat jemand ne idee, woran das liegen könnte?

Gruß
Roman

Attachment: pgpYccVuBlCaM.pgp
Description: PGP signature


Reply to: