[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: unmet dependencies bei unstable



Hi.
Am Dienstag, 30. September 2003 17:31 schrieb Adrian Bunk:
> On Tue, Sep 30, 2003 at 04:08:59PM +0200, Markus Hansen wrote:
...
> > Sorry, but the following packages have unmet dependencies:
> >   ksysguardd: Depends: libsensors-1debian1 but it is not installable
> > E: Sorry, broken packages
> > LordKelvinAthlonXP:/home/markus# apt-get -s install libsensord-1debian1
> > Reading Package Lists... Done
> > Building Dependency Tree... Done
> > E: Couldn't find package libsensord-1debian1
>
> Und wer unstable verwendet sollte das Debian Bug Tracking System kennen:
>
>   http://bugs.debian.org/ksysguardd
>
> Das ist scheinbar ein bekanntes Problem mit dem ksysguardd-Paket in
> unstable.
> > LordKelvinAthlonXP:/home/markus#
> > ***********
> >
> > > Daneben:
> > > Ist bei dem Backport kdelibs4 mit g++ 3.2/3.3 kompiliert oder der Name
> > > des Pakets geaendert (mit Konflikt gegen kdelibs4)? Ansonsten wuerde
> > > ich dir empfehlen, mit einem
> > >   apt-get remove kdelibs4
> >
> > Wofür werden kdelibs4 denn gebraucht?
>
> Das sind die zentralen KDE-Bibliotheken.
>
> > > anzufangen und danach die KDE-Pakete neu zu installieren.
> >
> > Na, das geht ja nicht, oder verstehe ich da irgendetwas von Grund auf
> > falsch?
>
> Warum sollte das nicht gehen?

Naja, da kdebase das ksysguard bzw mittelbar das ksysguardd braucht, dann kann 
es ohne das nicht installiert werden, oder?
und wenn dieses Paket wegen unmet dependencies nicht installierbar ist 
(bugs.debian.org),
wie kann ich/man denn überhaupt KDE3.1.3 aus unstable installieren?
Verstehst du, was ich meine?

> >...
> > Also ich würde mal sagen g++ 2.95, da es ja ein "woody"Paket ist.
> > ************
> > LordKelvinAthlonXP:/home/markus# apt-cache policy kdelibs4
> > kdelibs4:
> >   Installed: 4:3.1.3-0woody1
> >...
>
>   dpkg --status kdelibs4
>
> Wenn das Paket von libstdc++2.10-glibc2.2 abhaengt ist die g++ 3.3
> Transition beim Backporten nicht vernuenftig rueckgaengig gemacht
> aworden und es kann leicht sein, dass dir ein normales Upgrade um die
> Ohren fliegen wird wenn du nicht vorher KDE komplett deinstalliert hast.

Also ich würde sagen, es hängt davon nicht ab:
*********************************************************
LordKelvinAthlonXP:/home/markus# dpkg --status kdelibs4
Package: kdelibs4
Status: install ok installed
Priority: optional
Section: libs
Installed-Size: 16688
Maintainer: Ralf Nolden <nolden@kde.org>
Source: kdelibs
Version: 4:3.1.3-0woody1
Replaces: kdelibs3 (<< 4:3.0.0), kdelibs3-cups (<< 4:3.0.0), kdepim-libs (<< 
4:3.0.0), libkmid (<< 4:3.0.0), libkmid-alsa (<< 4:3.0.0)
Depends: libart-2.0-2, libarts1 (>= 1.1.3), libasound2 (>= 0.9.0beta10a-1), 
libaudiofile0 (>= 0.2.3-4), libbz2-1.0, libc6 (>= 2.2.4-4), libcupsys2 (>= 
1.1.13-1), libfam0, libjpeg62, libldap2 (>= 2.0.23-1), libmad0 (>= 0.14.2b), 
libogg0 (>= 1.0rc3-1), libpcre3, libpng3, libqt3-mt (>= 3:3.1.2), libsasl7, 
libstdc++2.10-glibc2.2 (>= 1:2.95.4-0.010810), libtiff3g, libvorbis0 (>= 
1.0rc3-1), libxml2 (>= 2.4.19-4), libxslt1 (>= 1.0.16), xlibs (>> 4.1.0), 
zlib1g (>= 1:1.1.4), kdelibs-bin (= 4:3.1.3-0woody1), kdelibs-data (= 
4:3.1.3-0woody1)
Conflicts: kdelibs3 (<< 4:3.0.0), kdelibs3-cups (<< 4:3.0.0), kdepim-libs (<< 
4:3.0.0), libkmid (<< 4:3.0.0), libkmid-alsa (<< 4:3.0.0)
Description: KDE core libraries
 KDE core libraries.
 You need these libraries to run kde applications.

LordKelvinAthlonXP:/home/markus#
******************************************************
> > MFG
> > Markus Hansen
>
> Gruss
> Adrian
>
> --
>
>        "Is there not promise of rain?" Ling Tan asked suddenly out
>         of the darkness. There had been need of rain for many days.
>        "Only a promise," Lao Er said.
>                                        Pearl S. Buck - Dragon Seed

-- 
Markus Hansen
markus@spamfreemail.de



Reply to: