[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Accès réseau via USB défaillant (après installation OpenVPN)



Conflit entre quoi et quoi ?
Quelles commandes me permettront de savoir ce qui se passe là-dessous ?
Merci
----- Original Message -----
From: Philippe Lacueille <lacueille.philippe@neuf.fr>
To: roger tarani <roger.tarani@free.fr>
Sent: Mon, 20 Aug 2018 19:37:32 +0200 (CEST)
Subject: Re: Accès réseau via USB défaillant (après installation OpenVPN)

Bjr. 
Ça sent le conflit d’ip. 
Cela pourrait être une piste ?
Cordialement 
Philippe 

Envoyé de mon iPhone

> Le 20 août 2018 à 18:52, roger.tarani@free.fr a écrit :
> 
> Bonjour
> 
> j'ai configuré une machine Debian Jessie avec x2go server. rq : j'ai du installer le bureau XFCE car le bureau Gnome 3 ne permettait pas d'accéder via x2go à la machine.
> La connexion avec x2Go client (ou ssh, simplement) via le LAN fonctionne normalement.
> Puis, j'ai configuré OpenVPN client qui fonctionne normalement (c'est le VPN SSL de la Freebox Revolution).
> 
> Maintenant, j'ai un nouveau problème : lorsque je connecte un iPhone (partage de connexion) ou un MiFi (un Domino modem 4G/routeur WiFi), la machine n'arrive plus à se connecter à l'internet (par exemple, pour un sudo apt-get update) ni au VPN.
> 
> Précédemment (avant x2go et OpenVPN), j'ai pu utiliser un modem USB (iPhone ou Domino) pour accéder normalement à internet depuis cette machine.
> 
> Sur une autre machine similaire en Jessie, l'iPhone et le Domino donnent accès à internet. La machine peut simultanément faire un sudo apt-get update via l'interface USB offerte et se connecter au serveur VPN distant comme attendu.
> 
> Enfin, je vois que la connexion USB Ethernet sur la machine problématique apparaît momentanément dans la barre de menu comme "unmanaged" puis cette information disparaît de Network Manager/du tableau de bord
> 
> C'est une question à part entière : comment configurer la machine pour que Network Manager soit synchrone avec ce qui se passe en CLI ?
> 
> Sur l'autre machine Debian Jessie qui fonctionne bien, j'ai le même problème _non bloquant_ de désynchronisation entre ce que fait la machine en CLI (bien, dans son cas) et ce qu'indique NetworkManager. Quoique dans son cas, dans Settings/Networks je vois "Wired" pour la connexion via USB (iPhone/Domino).
> 
> Network Manager a une réputation trouble. Et j'ai eu des problèmes avec par le passé (Jessie).
> Faut-il désactiver Network Manager et choisir un autre outil ?
> Ou faut-il tout désactiver pour traiter exclusivement le réseau en CLI ?
> 
> PS : quelle est la manière propre et adaptée à Debian Jessie pour lancer automatiquement la connexion OpenVPN au démarrage de la machine ? (j'ai joué avec différentes commandes mais ça semble brouillon)
> 
> 
> Merci



Reply to: