[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Probleme d' aptitude



Le mercredi 31 janvier 2007 22:08, Georges Roux a écrit :
> Bonjour,
>
> Ayant fait une mise a jour de tout les paquets avec Synaptic, tout c'est
> bien passé,
> maintenant quand j'utilise aptitude,
> que je fait une mise a jour de la liste avec:
> aptitude update
> puis que je lance une mise a jour:
> aptitude upgrade
> Aptitude me propose de supprimer 182 paquets sous prétexte qu'il ne sont
> pas utilisé.
> Donc a mettre a jour 0, a installer 0, 182 a enlever
> Hors il y a plein de paquets dont je me sert tout les jours, OOo, cups,
> totem, gnome-system-tools...
>
> Apparemment il y a divergence entre Aptitude et Synaptic, et Aptitude
> est aux fraises, comment résoudre ce problème.
>
> Georges

Malheureusement, seulement aptitude supporte la notion de paquet installé 
automatiquement, à cause d'une dépendance.
Ça lui permet de désinstaller les paquets qui ne sont plus utiles dès qu'on 
désinstalle ceux qui ont provoqué leur installation.

Avec apt-get et synaptic, il faut utiliser régulièrement deborphan pour arrivé 
au même résultat.

En conclusion, je n'utilise plus qu'aptitude, c'est le seul que l'on peux 
utiliser de n'importe où, interface texte ou ncurses. Et j'aime bien gardé un 
système le plus minimaliste possible. Je désactive d'ailleur aussi 
l'installation des paquets recommandés.

Pour corrigé ton problème, le plus propre est d'aller dans aptitude et marquer 
à nouveau à installer tout ce qu'il propose de désinstallé et que tu sais 
très bien que tu utilises.

Attachment: pgp6AhearGSal.pgp
Description: PGP signature


Reply to: