[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: paquets corrompus : comment les réparer ?



Le 12805ième jour après Epoch,
Gerard Kohler écrivait:

> bonjour,
>
> je n'arrive pas à enlever ou installer des paquets sans que dpkg me
> signale des paquets corrompus.
>
> voici le résultat de
>      :# dpkg -l |grep -v ^ii
>
> Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
> | état=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé
> |/ Err?=(aucune)/H=é garder/besoin Réinstallation/X=les deux (état,Err: majuscule=mauvais)
> ||/ Nom            Version        Description
> +++-==============-==============-============================================
> rc  nfs-kernel-ser 1.0.6-3        Kernel NFS server support
> rc  webmin-heartbe 1.160-3        heartbeat monitor control module for webmin
>
>
>
> lorsque je fais :
> 	:# dpkg -r webmin-heartbe
>
> cela me dit :
> 	dpkg - avertissement : requête ignorée : suppression de webmin-heartbe, qui n'est pas installé.
>
> de même pour nfs-kernel-ser
>
>
> Comment m'en sortir ?

Plusieurs choses:

1) Pour voir le nom complet des paquets non installés, il vaut mieux
   faire "COLUMNS=130 dpkg -l |grep -v ^ii" 

2) Désinstaller un paquet qui ne l'est pas, me semble quelque peu
   original non?

>     je veux enlever tous les paquets d 'apache2 pour remetre apache 1....
> mais il me demande de supprimer phpmyadmin, suis-je obligé de
> l'enlever puis de le réinstaller ? ou existe-t-il un moyen pour
> contourner cela ?

A mon avis, une simple demande d'install de Apache devrait
suffire. Mais je n'en suis pas sûr.



Reply to: