[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Distribution d'OpenOffice sous Debian



On Tue, 6 Jan 2004 10:45:36 +0100
georges mariano wrote:

> On Tue, 6 Jan 2004 09:19:25 +0100
> Gaëtan PERRIER <gaetan.perrier@free.fr> wrote:
> 
> > 
> > Ouais mais bon ça fonctionne complétement contrairement à la
> > version debian...
> > 
> 
> Bon, j'explorais récemmment le sujet "Debian et Java"... ben c'est
> franchement pas très clair.
> 
> Prenons ce fil comme étude de cas :
> 
> 0) mettons de côté temporairement les aspects libre/non-libre 
> (pour ne pas parasiter la discussion technique) [moi non plus j'aime
> pas trop mettre les pieds dans java mais, admettons...] 
> 
> 1) que faudrait-il pour avoir un Openoffice(/Java) pleinement
> opérationnel sur la base d'une debian ?
> 
> 1a) en prenant comme point de départ les paquets openoffice de
> debian
> 
> 1b) si impossibilité **technique**, quel autre point de départ ?
> 
> Si j'ai bien compris, autre formulation, lorsque l'installeur
> openoffice pose la question du support java, que doit-il y a voir
> sur la machine à ce moment là pour que ça roule ? 
Je ne peux pas répondre à tes précédentes questions. J'évoquais
simplement le fait que les fonctionnalités liées à Java étaient
désactivées ou enlevées (je pense lors de la compilation) par le
mainteneur du paquet. Si tu installes la version complète
d'OpenOffice, Java n'est pas nécessaire pour le faire fonctionner,
seulement, certaines fonctionnalités seront absentes. Par exemple, une
partie de l'aide est écrite en Java. Je suppose donc que sans Java,
une partie de l'aide serait inaccessible.
En plus, OpenOffice nécessite une version de Java assez récente. Si
mes souvenirs sont exacts, le version Java disponible pour Woody est
trop obsolète (celle qu'on trouve sur Oleane.net). Je crois qu'il faut
la version 1.4.x mini. J'ai cherché sur le site d'OpenOffice où il est
indiqué qu'il faut télécharger la dernière version de java...
Toutefois, si Java n'est pas installé avant OpenOffice, ce n'est pas
un problème. Il suffit de relancer la détection de Java par le biais
du programme jvmsetup qui se trouve dans le répertoire
d'OpenOffice/program.
En ce qui me concerne, j'ai installé la dernière version de JRE
téléchargée sur le site de Sun.
> 
> Merci
> -- 
> 		mailto:mariano.georges@free.fr
> debfr-faq : http://savannah.nongnu.org/download/debfr-faq/html/
laurent

-- 
    .~. 
    /v\   ****Laurent****
   // \\ laurux_NO_SPAM@freesurf.fr
  /(___)  Clé 6E9B2489 sur pgp.mit.edu
   ^   ^ [=====Debian=GNU/Linux====>


Attachment: pgpJ8APfHMfcH.pgp
Description: PGP signature


Reply to: