[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Entreteniments variats després d'actualitzar a Bullseye



Bones,

Us comento els meus "posters gais" per si algú s'hi ha trobat i em pot donar un cop de ma, després d'actualitzar a Bullseye em trobo que:

ufw no arrenca i aparentment hauria de fer-ho

lluis@ns:~$ systemctl list-unit-files | grep -i ufw
ufw.service                                enabled         enabled

La cosa peta per unes regles afegides a /etc/ufw/before.rules per incorporar dos conjunts d'ipset que en idèntica configuració, funcionen sense problemes a una altra màquina amb Buster

root@ns:~# systemctl status ufw.service
● ufw.service - Uncomplicated firewall
     Loaded: loaded (/lib/systemd/system/ufw.service; enabled; vendor preset: enabled)
     Active: failed (Result: exit-code) since Sat 2021-08-28 11:52:52 CEST; 1min 51s ago
       Docs: man:ufw(8)
    Process: 289 ExecStart=/lib/ufw/ufw-init start quiet (code=exited, status=1/FAILURE)
   Main PID: 289 (code=exited, status=1/FAILURE)
        CPU: 44ms

d’ag. 28 11:52:52 ns ufw-init[354]: iptables-restore v1.8.7 (nf_tables): Set Firehol_L1 doesn't exist.
d’ag. 28 11:52:52 ns ufw-init[354]: Error occurred at line: 88
d’ag. 28 11:52:52 ns ufw-init[354]: Try `iptables-restore -h' or 'iptables-restore --help' for more informatio>
d’ag. 28 11:52:52 ns ufw-init[633]: Problem running '/etc/ufw/before.rules'
d’ag. 28 11:52:52 ns systemd[1]: ufw.service: Main process exited, code=exited, status=1/FAILURE
d’ag. 28 11:52:52 ns systemd[1]: ufw.service: Failed with result 'exit-code'.
d’ag. 28 11:52:52 ns systemd[1]: Failed to start Uncomplicated firewall.
Warning: journal has been rotated since unit was started, output may be incomplete.

A /etc/ufw/before.rules hi tinc

-A ufw-before-input -m set --match-set Firehol_L1 src -j DROP

-A ufw-before-input -m set --match-set UFWBlockList src -j DROP

I bàsicament un parell de scripts que s'executen des del cron i alimenten /etc/iptables/ipset, alguna cosa com

#!/bin/sh

ipset create UFWBlockList hash:ip -exist

ipset flush  UFWBlockList

for i in $(cat /var/log/messages | grep BLOCK | awk -F= '{print $5}' | cut -d " " -f 1 | sort | uniq -c | awk '{ if ($1 >=10) print $2}'); do ipset add UFWBlockList $i; done

ipset del UFWBlockList 127.0.0.1 -exist

ipset del UFWBlockList 192.168.0.2 -exist

ipset save -file /etc/iptables/ipsets


De moment i per estalviar-me una bona estona de desconnexió estic forçant un ufw reload a /etc/rc.local, però entenc que hi ha d'haver alguna explicació i m'agradaria saber-la.

pulseaudio es comporta erràticament amb el nucli 5.10.0-8-amd64, només escolto so amb la configuració HDMI (5.1) i els vídeos s'acceleren, en canvi amb el darrer nucli de Buster, el 4.19.0-17-amd64, la cosa funciona correctament, però ni en un cas ni en l'altre funciona la comprovació dels altaveus. No sembla un problema de maquinari perquè arrencant amb una distro en viu funciona correctament. El systemctl no indica res estrany

lluis@ns:~$ systemctl --user restart pulseaudio.service
lluis@ns:~$ systemctl --user -l --no-pager status pulseaudio*
● pulseaudio.service - Sound Service
     Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; enabled; vendor preset: enabled)
     Active: active (running) since Sat 2021-08-28 12:09:22 CEST; 5s ago
TriggeredBy: ● pulseaudio.socket
   Main PID: 58747 (pulseaudio)
      Tasks: 4 (limit: 9342)
     Memory: 6.5M
        CPU: 174ms
     CGroup: /user.slice/user-1004.slice/user@1004.service/app.slice/pulseaudio.service
             └─58747 /usr/bin/pulseaudio --daemonize=no --log-target=journal

d’ag. 28 12:09:20 ns systemd[1526]: Starting Sound Service...
d’ag. 28 12:09:22 ns systemd[1526]: Started Sound Service.

● pulseaudio.socket - Sound System
     Loaded: loaded (/usr/lib/systemd/user/pulseaudio.socket; enabled; vendor preset: enabled)
     Active: active (running) since Sat 2021-08-28 11:53:01 CEST; 16min ago
   Triggers: ● pulseaudio.service
     Listen: /run/user/1004/pulse/native (Stream)
     CGroup: /user.slice/user-1004.slice/user@1004.service/app.slice/pulseaudio.socket

d’ag. 28 11:53:01 ns systemd[1526]: Listening on Sound System.

En fi que s'agrairia una mica de llum ;-)


Reply to: