[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Grub, sparc64, and compressed kernels

On Tue, Jul 03, 2018 at 04:43:32PM -0400, Chris Ross wrote:
> [- tried to grub-install onto /dev/sda1 and /dev/sda2, won't boot, Illegal
>    Instruction. -]

> So, I fear some of this is based on the fact that I'm running grub-install
> into raid filesystems that are mounted as a RAID1, but I'm sticking things
> into them at the same time.  Or maybe it's more complicated, but the fact
> that I'm writing into the raw partitions under an md RAID certainly seems
> of concern.  :-/

So I'm even more confused now.  I was unable to boot disk0 or disk1, but
also got errors booting off of disk3, which had been working.  So I booted
into rescue cd, re-ran the grub-install onto /dev/sdd1, then rebooted.
Came up fine, as before.  When it did, I did nothing but log in, then 
re-run "grub-install --force --skip-fs-probe" onto each of /dev/sda1 and
/dev/sda2, while /dev/md0 wasn't mounted.  Nothing on the first three
disks had been accessed since boot.

Sadly, this did not make those disks bootable either.  But, surprisingly,
I now can't boot off of disk3 again.  Even after a "reset-all", I see:

Boot device: disk3  File and args: 
GRUB ERROR: Last Trap: Illegal Instruction

So, I've no idea how merely running grub-install onto /dev/sda1 and
/dev/sdb1 could possibly have messed up the grub on /dev/sdd1?  I am booting
into rescue cd again now to repair that, but I'm starting to feel that
grub is acting for some evil spirit and I am failing to meet whatever
it's needs are....

                    - Chris

ps, re-grub-install'ing to /dev/sdd1 allowed the system to boot again.
I rebooted a few times, seems to have remained functional.  I also after
a few successful boots to sdd (aka disk3), tried booting from PROM to
disk0 again, got the Illegal Instruction, but was then still able to 
boot disk3.

Reply to: