[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: How to boot SUN T5220?

Hash: SHA256

On 05/09/2011 05:04 PM, Jurij Smakov wrote:
> On Mon, May 09, 2011 at 04:22:13PM -0300, Flamarion Jorge wrote:
> On 05/09/2011 01:46 PM, Ivan Jager wrote:
>>>> On Mon, May 09, 2011 at 09:57:50AM -0300, Flamarion Jorge scribbled:
>>>>> Hash: SHA256
>>>>> On 05/05/2011 08:56 PM, Flamarion Jorge wrote:
>>>>>> Hello all,
>>>>>> I am the Flamarion Jorge and I'm from Brazil.
>>>>>> I joined this list for two reasons:
>>>>>> 1 - I understand very little about the SPARC architecture, which must
>>>>>> have an installed Debian and it works well.
>>>>>> 2 - I really want to report a successful installation for staff of the DI
>>>>>> So here we go
>>>>>> Today all afternoon here in Brazil (GMT -3) I tried unsuccessfully to
>>>>>> get a boot with Debian installed on SUN T5220.
>>>>>> Initially I did a normal installation using a traditional partitioning
>>>>>> using EXT3 and SWAP.
>>>>>> After some reading on the Internet I saw that it was necessary to have a
>>>>>> primary partition in UFS and EXT2 format, and has a partition table with
>>>>>> the label SUN.
>>>>>> Well, I tried to do this manually, without success. I tried to leave the
>>>>>> DI guided partitioning, without success. I tried, tried and tried .....
>>>>>> I read a lot, but unfortunately I can reach the end of successful
>>>>>> installation, with all the hardware detected and functional, but I can
>>>>>> not boot from a ILOM.
>>>>>> The only way I could access my Debian on SUM T5220 was through the
>>>>>> rescue mode of DI.
>>>>>> So after all this saga, I'd like a hint of you on how to make Debian
>>>>>> boot properly SILO from the ILOM.
>>>>>> This machine is at my disposal, so I can try any hint that you want to
>>>>>> post so we can report a successful installation of for the DI guys and
>>>>>> the staff of the SPARC port.
>>>>>> Thank you very much
>>>>> Hi again,
>>>>> Can anyone give me a hint to help start the SILO?
>>>> Yes, but sorry it's going to be rather obvious since you didn't
>>>> go into detail as to what the problem was. Go to openfirmware
>>>> (the ok prompt) and type "boot disk" (or whatever is needed to
>>>> boot of the disk where you installed silo). Then, (this is the
>>>> important part) observe what *does* happen. If you can't figure
>>>> out how to fix it, it would be easier to help if you actually
>>>> tell us what happened. If there is an error, you may want to copy
>>>> and paste it. If there is no output whatsoever, you would want to
>>>> say that. If it only prints "S" you would want to say that. It's
>>>> a bit hard to guess what went wrong if all you say is that it was
>>>> unsuccessful.
>>>> As for the SUN disklabel, you seem a bit confused about that, but
>>>> it may just be the translation from Portuguese. SUN does not use
>>>> the same partitioning scheme as the DOS partitions you are
>>>> probably used to. It's not that you need a partition with a label
>>>> of SUN, it's that you should be using a sun disklabel rather than
>>>> a DOS partition table. But if you're using the installer to
>>>> partition the disk, that shouldn't be a problem as it will do the
>>>> right thing. If you're partitioning manually and want more
>>>> details check man fdisk or
>>>> https://secure.wikimedia.org/wikipedia/en/wiki/BSD_disklabel but
>>>> I don't think that's actually the problem.
>>>> Ivan
> First thanks for trying to help me.
> My problem is: I can not load the silo from the "ok prompt"
> When i install Debian, using guided partitioning of Debian Installer,
> and the installation finished successfully, after the first reboot I get
> the following message:
> {0} ok boot disk
> Boot device: /pci@0/pci@0/pci@2/scsi@0/disk@0  File and args:
> Bad magic number in disk label
> Can't open disk label package
> ERROR: boot-read fail
> Can't open boot device
>> Try 'boot disk1'.

Hi Jurij,

{0} ok boot disk1
Boot device: /pci@0/pci@0/pci@2/scsi@0/disk@1  File and args:
ERROR: boot-read fail

Can't open boot device

{0} ok

Aparentemente foi instalado no disk0.

Mais alguma sugestão ?

- -- 
Flamarion Jorge
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/


Reply to: