[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

enable second interface on hme (netra t1)

Hello everyone.
I've been running debian sparc on my netra t1 for so many years I'd practically forgotten all about it.
A couple nights ago, we had a very near lightning strike (though not a direct hit). It was quite something, as the charge in the clouds overhead would build up, it would set off one or two of the smoke alarms, then when the lightning discharged, they went off. It was eerie.

In any case, this has apparently permanently horked eth0 on my HME card.
eth1 still shows link when I plug in an ethernet cable, so I sez "no problem, I'll bring up eth1 and keep rolling" cept I'm really a novice here.

ifconfig does not see more than one interface on the HME. I tried playing dumb and just changing "eth0" to "eth1" in /etc/network/interfaces ... this, of course did nothing. Googling for "debian sparc hme configuration" unsurprisingly yeilds pages and pages of mailing list entries about the net-install cd.

I would imagine, that I need to configure something with the kernel module for HME?

I've tried putting the net-install cd back in the drive and booting in rescue mode, however in both r'escue' mode and 'expert' mode the "network configuration" section does not allow me to select a network interface, just to try dhcp or manually configure the "primary" network interface, meaning my horked eth0.

Can anyone help me here? How do I manually bring up eth1?
The OS has never thought eth1 existed, though it never bothered me 'till now.
I have a strong gut feeling that eth1 would still work if I could find a way to enable it on the OS.

thanks in advance for your help everyone,


Reply to: