[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RSC console redirection on a Fire 280R

On Sat, Jun 23, 2007 at 09:33:13PM +0200, Josip Rodin wrote:
> The relevant silo.conf bits are:
>   append="video=atyfb:off console=ttyS0,9600n8"

After carefully re-reading Documentation/serial-console.txt I've tried
this instead:

console=ttyS0,9600 console=tty0

And that got me the kernel output, but still no input. Then I figured,
maybe console=tty0 was the clincher, and so I removed both lines,
but that didn't work out at all (or at least the kernel got stuck on
something else, but I couldn't see *what*, from RSC). I reset and booted
with console=ttyS0, and the machine booted properly.

I've also previously unplugged the keyboard from the machine, hoping that
this will help. It didn't seem to make a difference (other than the PROM
simply reporting that there is no keyboard).

The tty-relevant dmesg messages are:

f0088588: ttyS0 at MMIO 0x7fe7e400000 (irq = 11) is a SAB82532 V3.2
Console: ttyS0 (SAB82532)
f0088588: ttyS1 at MMIO 0x7fe7e400040 (irq = 11) is a SAB82532 V3.2

I'm out of ideas right now.

     2. That which causes joy or happiness.

Reply to: