[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Remote printing from a Solaris box to a remote Debian-CUPS server

Richard Mortimer wrote:

> First off before you go too far down the manual configuration route. I just
> checked on my print server and if you do a
> dpkg-reconfigure cupsys-bsd
> It asks you if you want to setup the BSD lpd compatibility server.
> Maybe just take the entry out of inetd.conf and see if that fixes it for
> you. If not I've answered a few of your questions below. It might also be
> worth your while firing a message off to the Debian CUPS Maintainers at
> pkg-cups-devel@lists.alioth.debian.org
> Richard
> > -----Original Message-----
> > From: kap@tfh-berlin.de [mailto:kap@tfh-berlin.de] On Behalf
> >
> > thank you for your info. I have not had the time to
> > immediately apply your advice, but now I am eagerly trying
> > again to set up  my  printing network. According to your
> > advice I read the man-pages and inserted the named line into
> > the "/etc/inetd.conf"-file. I restarted the "inetd"-daemon
> > and the "cupsd"-daemon as well, but printing from my
> > SolarisBox to the remote "Debian-system" is still impossible.
> > When launching a print job from the SolarisBox,  an error
> > message appears in its console window telling me:
> >
> >         Message from kap on SolarisBox (???) [ Tue Aug 16
> > 13:31:28 ] ...
> >
> >         Error transfering print job 0
> >                  check queue for (rljet4p@Debian-system)
> > <EOT>
> >
> >
> > Meanwhile I learned from the docs that the inetd-daemon is
> > listening on port 515 for incoming print jobs; in which case
> > the cups-lpd daemon is started to handle the job. What I
> > don't know is:  How  can I tell whether the TCP-connection
> > from the SolarisBox to the Debian-system is OK? Is there a
> > means to test this connection? A sort of "ping" perhaps?
> >
> You can do
> telnet localhost 515
> Or probably more importantly do it from SolarisBox replacing localhost with
> the hostname of your debian system.
> If that works you will see "Connected to localhost", "Escape character is
> '^]'.". That says that you can get basic connectivity to lpd. Use ctrl-]
> then 'q' to get out of telnet.
> If it does not work then you have something wrong in the plumbing of
> cups-lpd into inetd.
> I've just had a look on my print server and I have the following in
> /etc/inetd.conf. I must admit to having not tried using lpd recently but
> have no reason to think that it wouldn't work.
> printer stream tcp nowait lp /usr/lib/cups/daemon/cups-lpd cups-lpd
> If you are getting a connection then it is probably worth looking in the
> cups logs at /var/log/cups/ they may give you an idea as to what is going
> on.


thank you very much. That helped a lot and things are now clearer to me. I
followed your advices and after a "dpkg-reconfigure cupsys-bsd" , a "apt-get
install telnetd" and numerous trials with "update-inetd" and "telnet" I came
to the point, where I could establish a telnet connection from "SolarisBox" to

SolarisBox > telnet Debian-system 515
Trying <IP-address> ...
Connected to SolarisBox
Escape character is '^]'.
Connection to SolarisBox closed by foreign host.

Unfortunately printing still doesn't work. That's frustrating and I'm rather
pointless at the moment. So I have to dig deeper into the subject.


Reply to: