[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Ultra1, printing via serial port?

Jan-Benedict Glaw wrote:

> On Fri, 2005-07-29 08:52:03 +0200, F. Kappen <kappen@tfh-berlin.de> wrote:
> > I have am Ultra1 with sarge installed (kernel 2.4.27-2-sparc64). I want
> > to use it as a headless printserver. Although I compiled a custom kernel
> > with "CONFIG_PARPORT_SUNBPP=m" enabled  the parallel port doesn't work.
> > Doing a  "cat ~/.bashrc > /dev/lp0" results in an error message on the
> > printer's display.
> Indeed, there are statements around that the sunbpp driver is broken,
> and was so for quite some time.
> > Next I tried to print via the serial port, but without success. I guess
> > that the serial port is not setup correctly. So can someone tell me
> > please where I can find  information about configuring the serial port
> > of an Ultra1.
> How did you actually try to print? The serial port is probably the
> interface with the highest number of user-defined settings, so you
> should outline what you actually did to print data with it.

The serial port of my Ultra1 is configured like this:

myUltra1: # eeprom ttyb-mode

The tty-section of my "/etc/inittab" looks like this:

#1:2345:respawn:/sbin/getty 38400 tty1
#2:23:respawn:/sbin/getty 38400 tty2
#3:23:respawn:/sbin/getty 38400 tty3
#4:23:respawn:/sbin/getty 38400 tty4
#5:23:respawn:/sbin/getty 38400 tty5
#6:23:respawn:/sbin/getty 38400 tty6

# Example how to put a getty on a serial line (for a terminal)
T0:23:respawn:/sbin/getty -L ttyS0 9600 vt102
#T1:23:respawn:/sbin/getty -L ttyS1 9600 vt100

The serial devices are:

myUltra1: # ls -la /dev/ttyS*
crw-------  1 kap2 tty     4, 64 2005-07-29 13:23 /dev/ttyS0
crw-rw----  1 root dialout 4, 65 2005-02-28 00:37 /dev/ttyS1
crw-rw----  1 root dialout 4, 66 2005-02-28 00:37 /dev/ttyS2
crw-rw----  1 root dialout 4, 67 2005-02-28 00:37 /dev/ttyS3
crw-rw----  1 root dialout 4, 68 2005-02-28 00:37 /dev/ttyS4

I am member of the "dialout" group.

The print command I tried was:

myUltra1: # cat ~/.bashrc > /dev/ttyS1

If I overlooked any  necessary information, please let me know. My hope is, that
someone of this discussion group uses the serial port of the Ultra1 (for printing)
and can supply me with his configuration


Reply to: