[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Ultra2 Booting problem

On Friday November 26 2004 6:34 am, Carlos Emir M. Macedo wrote:
>         Walt,
>         I had the same problem a few days ago. There are erros at your
> silo.conf.

Small problem; I am not getting a silo prompt. The prompt I get is: "{0} ok".
I believe the silo prompt will say "boot". I did the "boot 2/boot/vmlinuz" you 
indicated below.  I also tried variations of it, ie:  boot 1/boot/vmlinuz. No 
help! The lines below is what I got each time. (The first line is what I
entered at the prompt.)

{0} ok boot 2/boot/vmlinuz
Boot device: /sbus/SUNW, fas@e,8800000/sd@3,0 File and args: boot 2/boot/
The file just loaded does not appear to be executable.
{0} ok 

(The "vmlinuz" is on the next line because of Kmail's line wrap.)
Above is what is being displayed on my Untra2's screen. 

Is there any other possibilities??

I supose I could provide the contents of my nvram. Would this help?
I haven't bothered it as I am not overly sure what all the commands 
do, and I don't want to completely disable this machine. I have been
doing some reading from various web sites on the subject of nvram 
settings. There is a boot-file variable. What if I set this to the kernel?

I am open to any ideas, comments, ramblings, and maybe even insults.
I have this machine so I can learn about it. It looks like I going to get my
wish. I will need help. Sun hardware has the reputation of being bullet proof.

Walt L. Williams

FYI: I downloaded Solaris 10 tried to load only to have the install tell 
me that my "UltraSPARC I processors are supported by this release 
by the release of Solaris."  Great more wasted CDs.

>         First, you must know where are your vmlinuz files. Here the full
> path is:
>         2/boot/vmlinuz
>         At silo, do:
>         boot 2/boot/vmlinuz
>         It should work.
>         My silo.conf looks like:
> partition=2
> root=/dev/sda2
> timeout=10
> read-only
> default=linux
> image=/vmlinuz
>   label=linux
>   root=/dev/sda2
> #  initrd=/initrd.img
> image=/vmlinuz-2.4
>   label=linuxOK
>   root=/dev/sda2
> image=/vmlinuz-2.6-smp
>   label=linux-2.6-smp
>   root=/dev/sda2
> #  initrd=/initrd.old
> image=/vmlinuz-2.6-1proc
>   label=linux-2.6-1proc
>   root=/dev/sda2
>         The trick is to configure root= in each image.
>         It works for me.
>         Hope it helps.
>         Best Regards,
>         Emir
> =============================
> Carlos Emir Mantovani Macedo
> Suporte Técnico
> Tecnologia Bancária S.A.
> +55 11 3244-8321
> cmacedo@tecban.com.br
> http://www.tecban.com.br
> =============================

Reply to: