[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Solaris Emulation How?

I am attempting to run a simple solaris binary on
sparc debian on Ultra 5.
lsmod displays:
Module                  Size  Used by    Tainted: P
solaris                45480   0
ip_tables              14784   0
vfat                   11424   0  (unused)
msdos                   5896   0  (unused)
fat                    35872   0  [vfat msdos]
soundcore               4436   0  (unused)
ac97_codec             12248   0  (unused)
st                     28092   0  (unused)
sg                     26136   0  (unused)
8390                    6944   0  (unused)
parport_pc             26504   0
parport                31312   0  [parport_pc]

I made the directory tree /usr/gnemul/solaris and /usr/gnemul/sunos
I ran a simple test.  I did on solaris9, a ldd of bash to
get list of shared libraries needed to execute bash binary.
I coupled the listed solaris shared libs to /usr/gnemul/sunos/usr/lib
and the solaris version of 'bash' to /usr/gnemul/sunos/usr/bin .
I changed to directory /usr/gnemul/sunos/usr/bin and
tried to execute the solaris binary bash via ./bash but no go.
What am I doing wrong?

Reply to: