[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

NFS problem


I'm having a problem with NFS here. I tried to set up my Sparcstation 5
as NFS server using Sarge with the kernel NFS server. Everything works
fine as long as I don't copy anything to the NFS shares. I can copy
files from the share, I can creates directories and files there, I can
even copy small files to the share.

But when I try to copy a larger file to the share it completely hangs.
A file with a length of 0 is created on the share, but no data is copied
there. Worse yet, cp hangs. No Ctrl-C, no kill -9 can terminate it. And
if I issue a ls to see if anything happens in that directory it also
hangs in the same way.

I have tried the 2.2 and 2.4 kernels, to no avail. The userspace server
shows the same problems. I'm running another NFS server on a x86 box and
this one works just fine. So I don't think it is a problem on the client

I have no idea what's going wrong here, hopefully somebody here can give
me a hint at where to look?

Bye, Michael

If there's anything more important than my ego around here, I want it
caught and shot now!

Reply to: