[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [newbie] Installation problems


Hi again everybody,

Been fiddling with this a bit more last night. Giving 'linux root=/dev/sda1' at the SILO boot: prompt failed claiming the partition didn't exist. sda2 and sda3 were both detected by the loader but they caused 'bad magic number' claims and more kernel panicing.

One format in the single-user Solaris shell later (ie: much later) to restore the sun disklabels (I didn't realise 'label' in Solaris format would do this much faster...) and I'm getting pretty much the same issues, although the kernel now sees sda1 and sda7 as valid partitions

So far what I think is happening is, the kernel's not finding anywhere to put root which is acceptable to it - the disk's totally blank which might explain that, but even if I overwrite its attempt to netboot by specifying 'root=...' then it still doesn't work. I had a flash of inspiration and used 'root=/dev/ram' (as my RAMdisks are being configured ok) but that looked like it was just being ignored as the installer just tried to netboot anyway.

I'm pretty certain it'll all resolve itself if I can keep the kernel happy long enough to actually start the installation since it'll then have somewhere to put root once it's repartitioned the disk, but I can't see any way of doing that now, having exhausted all my inspiration :-(

Anyone? All suggestions appreciated :-)



It's fast, it's easy and it's free. Get MSN Messenger today! http://www.msn.co.uk/messenger

Reply to: