[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

something busted in fonts on debian/sparc in unstable?

Ok ok, I know this is what i get for running unstable.. but i did an
upgrade earlier today, and now suddenly everything that seems to use the
libXft/fontconfig/libfreetype/libxrender/libexpat combination seems to
segfault.  tried gvim, firefox, mozilla, xterm, konqueror, gaim..all
segfault almost immediately.. (living without xterm is extremely painful).
gdm works, in that it displays the initial greeter screen (unconfigured
since i never use it), but if you try and click on on one of the menu
items, etc, then it crashes.

Whats the best way to debug this?  I keep a pretty up to date system...
upgrading about once a week or so, and this is the first problem i've had
in three months.  But, of course, i don't have a log of the upgrade i did
(or at least i can't find one..)

strace isn't very helpful..it just segfaults somewhere after loading all
the libs...  gdb is even less-so:

$ gdb `which xterm`

GNU gdb 6.0 Copyright 2003 Free Software Foundation, Inc. GDB is free
software, covered by the GNU General Public License, and you are welcome
to change it and/or distribute copies of it under certain conditions. Type
"show copying" to see the conditions. There is absolutely no warranty for
GDB.  Type "show warranty" for details. This GDB was configured as
"sparc-linux"...(no debugging symbols found)... (gdb) run Starting
program: /usr/X11R6/bin/xterm

Program received signal SIGSEGV, Segmentation fault.
0x7100b594 in ?? ()
(gdb) bt
#0  0x7100b594 in ?? ()
#1  0x7100a8fc in ?? ()
#2  0x71003024 in ?? ()
The program is running.  Exit anyway? (y or n) y
$ xterm
Segmentation fault
$ ldd `which xterm`
        libXft.so.2 => /usr/lib/libXft.so.2 (0x71590000)
        libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x71b90000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x71a80000)
        libexpat.so.1 => /usr/lib/libexpat.so.1 (0x71b50000)
        libXrender.so.1 => /usr/lib/libXrender.so.1 (0x715d0000)
        libXaw.so.7 => /usr/X11R6/lib/libXaw.so.7 (0x71bcc000)
        libXmu.so.6 => /usr/X11R6/lib/libXmu.so.6 (0x71c38000)
        libXt.so.6 => /usr/X11R6/lib/libXt.so.6 (0x71cd0000)
        libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0x71d70000)
        libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0x71d40000)
        libXpm.so.4 => /usr/X11R6/lib/libXpm.so.4 (0x71b04000)
        libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x71800000)
        libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x71480000)
        libncurses.so.5 => /lib/libncurses.so.5 (0x70010000)
        libc.so.6 => /lib/libc.so.6 (0x71030000)
        libz.so.1 => /usr/lib/libz.so.1 (0x717b0000)
        libdl.so.2 => /lib/libdl.so.2 (0x71220000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x71000000)

The only think in commond on all the binaries (besides libX11 and libc)
are the use of libfreetype/libxft2/fontconfig.  Note, things that don't
use these... such as the gimp, rxvt, xfce 3, etc.. all run just fine.
also, fc-list runs fine with depends on all the libs in question besides
the libxft2 library... but i'm not sure if that proves anythign at all.

Is anyone else experiencing this on sparc, or is it just my configuration
that's gone completely nuts?  literally, everythign was working fine
before i upgraded at ~3pm today, and right after the upgrade all hell
broke loose...

Also, I tried to downgrade to testing, and seem to have failed.. changed
my sources.list to point to testing instead of unstable, then did an
apt-get update and an apt-get dist-upgrade, and it didn't do anything (0
packages upgraded).  what did i miss there?

Some pointed questions:
- does apt keep a log of everything it does so i can at least see what
packages got upgraded today and which ones didn't? it appears the .deb's
in /var/cache/apt/archive keep the datestamp of when they were uploaded,
not downloaded.

- If I discover the culprit package, is there a place where i can find the
previos sparc debs, or are they all gone once the upgraded ones get pushed
to the mirrors? (i'm guessing they're gone, unless they're in my cache'd
archive, which i cleaned out a few weeks ago).

- Any other pointers?  I'm hardly an apt or a debian expert..


John Clemens          http://www.deater.net/john
john@deater.net     ICQ: 7175925, IM: PianoManO8
      "I Hate Quotes" -- Samuel L. Clemens

Reply to: