[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: More SS20 confusion...

Hartwig Atrops wrote:


On Tuesday 09 March 2004 09:32, James Nelson wrote:
All right.  I've also tried booting from floppy, only to get an "illegal
instruction".  Then I tried a netboot, to get the same problem - it
downloads the boot file, and then halts with an "illegal instruction"
error.  I know it's not a massive hardware failure (I've got Solaris 9
running on it) and I'm just confused.

Just out of curiosity, is it possible to cross-compile a kernel?  I'm
just about ready to try a custom kernel out of sheer frustration, but
only have x86 machines available right now.

Never tried to cross-compile, no need to :-)

I just checked one of my SS20. I have two sets of debian CD-Roms, 3.0r0 and 3.0r1.

I attached an external SUN CD-Drive (narrow), externally terminated, inserted the first CD of both sets.

Then I switched on the SS20, STOP-A'd and typed 'boot cdrom'.
Both CD's boot without any problem into the debian release notes screen.

Which CD version did you use?

About netboot: I would like to try that, too. Do I have to convert the kernel in any way (I have seen something like this on MIPS), or can I use it just as it is?



I'm using 3.0r2. I guess I'll try the r1 release's first CD - time to jigdo some more CD's.

There's info on how to set up netbooting in the Debian-SPARC installation guide. The CD's come with tftp boot images - time to try the r1 tftpboot.img file.

Reply to: