[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 2.6.2 on SS20

I'm just about to compile up 2.6 for the first time on my SS20, which
has a dual 125MHz ross hypersparc card in it.  I've done heaps of 2.6
upgrades on x86 and powerpc, but I thought I had better check for
gotyas that other people might have run into - like the fact that
CONFIG_PREEMPT=y makes a powerpc machine randomly segfault processes :)

2.6.x SMP won't yet run on sparc32. Keith Wesolowski is working on it
(as time permits), so wait, do tests or just try to help woing work.
Please also join the sparclinux@vger.kernel.org mailing list.

Hi folks.

WRT Linux 2.6.x on SS20-MP, I get compile errors when attempting to build an SMP HyperSPARC kernel, just FYI. It "just won't work"(tm) at this stage.

I'm going to try and delve into the code, but I don't like my changes at this stage.

Other things that I have come across:

kernel-image-2.4.24-sparc32-smp package cannot be used because SILO complains that the uncompressed image is too large (Bug #234404).

sarge libc6 upgrade doesn't depend on 2.4 kernel, but requires it, leaving libc6* unconfigured until one is installed. (can't find a bug for this, but looks like the libc6 maintainers have more than enough to do without me hassling them)

I keep getting "Cannot file /etc/silo.conf (Unknown ext2 error)" when booting. It seems odd because it can read 1/vmlinuz without any problems.

Also, I got loads of kernel oopses on 2.4.25 when appending video=sbus:font=SUN12x22 on the kernel command line.

Cheers all.

James Whatever
My niece called me "Uncle Robot" on the weekend!
Giant Robot Ltd, http://www.giantrobot.co.nz/

Reply to: