[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Booting Debian on my IPX - I'm close

I finally got Debian installed on my IPX, with SILO included so I don't have
to use a boot floppy. Here are two issues that (I think) are the only things
keeping me from getting the system to boot Debian.

1. When I start up and get to the Openboot prompt, I type "b" to boot, and
get the error "SCSI device 3,0 is not responding. Can't open boot device."
This is because the SCSI ID of my hard drive is 1. If I go to new command
mode and do "boot /sbus/esp/sd@1,0" SILO starts to load, but...

2. The next thing I see is "SILO," followed by the following errors:

"Buggy old PROMs don't allow reading past 1GB from start of the disk. Send
complaints to SMCC

Read error on block 786436 (tried 4096, got -1)

Cannot find /etc/silo.conf (Unknown ext2 error)

Couldn't load /etc/silo.conf
No config file loaded, you can boot just from this command line
Type [prompath;]part/path_to_image [parameters] on the prompt
E.g. /iommu/sbus/espdma/esp/sd@3,0;4/vmlinux root=/dev/sda4
or 2/vmlinux.live (to load vmlinux.live from 2nd partition of boot disk)"

Whaaaaa? Most of this stuff doesn't make much sense to me, probably due to
my complete lack of experience with Sun hardware. For reference, my boot
drive has four partitions. 1 is /boot, 2 is swap, 3 is "whole disk," and 4
is / (root). I've tried a few different commands to get the system to boot,
without luck so far. What did I do wrong?


To UNSUBSCRIBE, email to debian-sparc-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: