[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: boot-floppies 3.0.21 for testing

* Adam Di Carlo <adam@onshore-devel.com> [020314 10:55]:
> I have uploaded sparc and powerpc builds of boot-floppies 3.0.21 for
> testing at:
>   http://people.debian.org/~aph/debian/dists/woody/main/
> We need help!  Our non-i386 testing is decidedly weak.  Please check
> these images and ensure that they don't have any crippling problems.
> This is the first set built purely from Woody.  Changelog for 3.0.21
> can be found below.
> Please send any replies to <debian-boot@lists.debian.org>.
> If they are ok, I will release boot-floppies 3.0.21.

I've just used the sun4u tftp image to net install an AX1105-500.  For
those not familar with this machine, it's a motherboard Sun sells to
VARs to build SPARC machines around.  It's more or less equivalent to
the Sun Blade 100 with some minor differences.

I initally booted the machine with the USB keyboard and mouse connected
(and a monitor)... got to the first prompt to select a keyboard (where
it was still working fine) and selected the us type 4/5, even though
this machine has a usb type 6.  That was a mistake... the keymap was
totally wrong.

I decided instead to go the route I usually took - the serial console.
This worked fairly cleanly with a few exceptions:

* My installation method was "network".  An improvement here is that the
  bogus /etc/resolv.conf problem is gone so DNS lookups work properly
  (yay!).  But on the down side, anywhere where it looks like there
  should be a progress bar shows nothing of any value.  Just a flashing
  cursor that sometimes moved.

* After installing the kernel image, I selected "Configure Device Driver
  Modules" but it complained that there were none to configure.  I'm
  thinking that it was looking for them in a .../2.4.18/ directory, but
  at this point:

  [11:46am] avocado:~$ uname -a
  Linux avocado 2.4.17 #1 Wed Mar 6 13:24:45 EST 2002 sparc64 unknown

  2.4.17 is clearly installed.  This is probably a one-liner typo.

* The biggest problem I ran info however was after the system was
  installed... running base-config, I couldn't see which item I was
  selecting from the lists or the yes/no questions (no cursor).

At this point, though, I have a working machine.  For all of you wanting
to install Debian on your SB100, this looks like a good candidate for
giving it a whirl.

Adam - if there's anything else you want me to try let me know either on
or off the list.  I've got a bunch of SPARCs here, ranging from the SS2
to this AX1105... I just figured this machine would be among the tougher
tests for starters. :)  If you've got this one, then most of the other
Ultras should work as well... no idea about the 32-bit machines.  Did
you stick with a 2.2.x kernel for those?  If so, you're probably safe.

Reply to: