[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Kernel Problems with System.map


I have been running 2.2.20 on Debian Sparc (Potatoe) for the past 4
weeks without a problem.  I moved to 2.2.20 from 2.2.19 because I had
this same problem.  I compiled the kernel and installed it as follows:

make menuconfig && make dep && make vmlinux && make modules && make
cp /usr/src/linux/System.map /boot/System.map-2.2.20
cp /usr/src/linux/vmlinux /boot/vmlinuz-2.2.20

I have now done this 15 times in succession with the same result.  I
have even unpacked the source from the tar again and re-entered my
configuration as opposed to loading a saved one.  The machine will boot
the new kernel fine without any problems until I issue a ps or a top.

I know for a fact my System.map is the correct one, but I still get
errors about it not matching kernel data.  When I had this error on
2.2.19 it was moaning about a different exported symbol.  Under 2.2.20
it seems to be consistent with iommu_release_scsi_one.  This doesn't
seem to be causing problems to the system, but as you can imagine is
highly irritating.

> chris@hantu:~$ ps ax
> {iommu_release_scsi_one} {___f_mmu_release_scsi_one}
> Warning: /boot/System.map-2.2.20 does not match kernel data.
> {iommu_release_scsi_one} {___f_mmu_release_scsi_one}
> Warning: /usr/src/linux/System.map does not match kernel data.
>     1 ?        S      0:01 init
>     2 ?        SW     0:00 [kflushd]

I have also included the output from ver_linux:

> Linux hantu 2.2.20 #1 Thu Mar 14 19:38:47 GMT 2002 sparc unknown
> Gnu C                  2.95.2
> Gnu make               3.79.1
> binutils     
> mount                  2.10f
> modutils               2.3.11
> e2fsprogs              1.18
> Linux C Library        2.1.3
> Dynamic linker (ldd)   1.9.11
> Procps                 2.0.6
> Net-tools              1.54
> Console-tools          0.2.3
> Sh-utils               2.0
> Modules Loaded         sunlance


Reply to: