[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

DM9102A & Netra X1 (Was Re: Netra X1 boot getting closer)

Good news I now have the network working. I'm seeing a number of
transmit timeouts (see below) but don't seem to be losing packets.
I found that as well as clearing bit 21 in csr0 that I also had to
clear bit 24. That makes the csr0 assignment

static int csr0 = 0x00800000 | 0x9000

I suspect that the timeouts that I'm seeing probably have something to
do with other dm9102A/pci effects. I will keep trying differing
settings to see what effects they have.

As for the timeouts I'm seeing

NETDEV WATCHDOG: eth1 transmit timed out

Whilst doing pings I get this message around 8 times a
minute. Sometimes I see a number of pings sitting waiting to go and
then suddenly I get a flurry of them (maybe up to 15 seconds late). I
think that this is consistent with the transmit timeouts.


P.S. This is running 2.4.6-pre7 or thereabouts. I didn't need to go
back to earlier versions to get the network errors removed. I guess
that I ought to update to current cvs now that I seem to be making
definite progress.

Richard Mortimer writes:
 > Ben Collins writes:
 >  > On Sat, Jul 21, 2001 at 12:14:49AM +0100, Richard Mortimer wrote:
 >  > > We may be able to scrap the dmfe.c idea and keep with tulip. I did a
 >  > > bit of looking into why I was seeing pci errors with the tulip
 >  > > driver. After a bit of scratching around and a bit of a helpful
 >  > > suggestion from a colleague it seems that the dm9102a chip has a bit
 >  > > of a problem with Memory Read Multiple pci transactions (That is CSR0
 >  > > bit 21). If the MRM bit is cleared the pci errors go away and the chip
 >  > > starts to act a bit more reasonably. 
 >  > 
 >  > This sounds an awful lot like the problems I am having with tulip on my
 >  > g4, so it may not be an X1 issue. I had to back down to a version from
 >  > around 2.4.[34]. Maybe you could try copying the tulip directory from
 >  > that kernel version to 2.4.7, apply your patch and see how that works?
 > I tried that and got the same result. Do you think it might be worth
 > trying 2.4.[34] on the X1 (with hand crafted patches to get the
 > machine to run at all?).
 > Richard
 > -- 
 > Richard Mortimer - richm@oldelvet dot netscapeonline dot co dot uk

Reply to: