[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Ultra1 Creator quirks

Thus spake John Wood (jcw2@interq.or.jp):

> <snip>
> i have found that i am unable to get any gl based x applications to use
> the hardware. i was mostly testing with xscreensaver-gl applications. 
> later, i was able to get some results from the evas stuff, but only when i 
> select something besides hardware gl. clicking hardware would
> cause a segfault. 

Now thats wierd. I'm quite sure I am using the hardware when I run
opengl programs, and they don't crash, just thrash. Proof of DRI use is
not only given in the framerate difference (~350 vs. 60) but also in the
XFree86.0.log (as you can see in the bottom of
http://ultrasoul.com/ultra1/XFree86.0.log) when it creates the DRI GLX

FFB: Allocated WID 1 for DRI window.

I'm going to try the evas demo on here and see what happens. Ugg its not
pretty, all black except grey where the words should be flying in.. I'll
play more with that later.

> > syslog:
> > [drm:drm_release] *ERROR* Process 222 dead, freeing lock for context 1
> yes, this happens to me, although X does not die. there is a decent amount 
> of colour and pixel corruption in X in general. i do not get massive
> corruption with gl apps, but i do not think they are using the hardware
> either. 

Nod. When I prohibit the loading of the kernel DRI module, I don't get
corruption with OpenGL programs. I do get minor pixel corruption in the
normal 2D Xserver though, something to do with their XAA accelerations,
because they disappear if I add Option "NoAccel" to the Device section
of my XF86Config file. The corruption is limited to just a few random
white pixels being placed when I drag a window (box outline). And now
that I've tried opaque dragging, the pixel corruption doesn't happen,
but of course the windows move much slower. 

> something is definately not quite right. drm appears to init correctly
> (both in dmesg & x's log), but even simple things like moving non-opague
> windows around seem to put a pretty heavy load on the server. im not
> expecting blazing speeds, but this plus the gl problems leads me to
> believe i must be doing something wrong. then again, maybe it is supposed
> to perform like this? how are things like your opague window movements,
> and x's performance in general during other i/o & cpu intensive operations?
> mine are really unimpressive. maybe this is more an issue with X 4.1 than
> drm/creator?

Well, the only other Sun machine I have here is an IPX, and that is
_really_ 'unimpressive' :). I haven't run Solaris on this Ultra1 so I
can't compare to that. My opaque window movements seem fine, almost
normal compared to x86 machines (XFree86 jumps to ~20% CPU load and 15%
RAM) but everything keeps chugging. And during periods of heavy I/O and
CPU it doesn't impact my X performance noticably at all. 

This is very strange that we are getting such different results, and
neither positive. Take a look at my XF86Config file
(http://ultrasoul.com/ultra1/XF86Config-4) and see if anything is

I'll post my kernel config, too. Diff it with yours and tell me what you

Reply to: