[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Ultra1 Creator quirks

hi david
On Wed, 1 Aug 2001, David Smith wrote:

> find any reference to the bugs below in the database, has anyone else
> experienced these?

yes and no. i have a ultra1/170 & creator 3d. i am running unstable with
vgers kernel as well.
> 1) Running any OpenGL program with DRI hardware accleration enabled
> causes massive display corruption (test with glxgears). Colors are also

i have found that i am unable to get any gl based x applications to use
the hardware. i was mostly testing with xscreensaver-gl applications. 
later, i was able to get some results from the evas stuff, but only when i 
select something besides hardware gl. clicking hardware would
cause a segfault. 

> syslog:
> [drm:drm_release] *ERROR* Process 222 dead, freeing lock for context 1

yes, this happens to me, although X does not die. there is a decent amount 
of colour and pixel corruption in X in general. i do not get massive
corruption with gl apps, but i do not think they are using the hardware

something is definately not quite right. drm appears to init correctly
(both in dmesg & x's log), but even simple things like moving non-opague
windows around seem to put a pretty heavy load on the server. im not
expecting blazing speeds, but this plus the gl problems leads me to
believe i must be doing something wrong. then again, maybe it is supposed
to perform like this? how are things like your opague window movements,
and x's performance in general during other i/o & cpu intensive operations?
mine are really unimpressive. maybe this is more an issue with X 4.1 than


  john wood

  systems administrator, gmo inc 

Reply to: