[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: nightmare: apt slink->potato using cds

Thanks to the people who helped me get past the "apt-get
refusing the cd" problem.  I had to change the contents
of /var/state/apt/cdroms.list (otherwise known as the
cdrom index file).

Now I find that:

1)  the depmod -a in the /etc/init.d gives a _lot_ of symbol
not found warnings, because it keeps finding the modules in
the /lib/modules/2.2.1 directories (I've upgraded to 2.2.17).
AFAICT, the config files are correct (I believe I just accepted
all the new ones in the install).  modprobe -c does not list
any 2.2.1 directories.  My 2.2.1 modules are in 2.2.1
directories (not 2.2 directories).  I don't have
any 2.2 directories in /lib/modules.

2)  ipchains has turned off my email.  Ie, I have been
downloading email from my isp using fetchmail, then
sending it to a local MTA (exim) for delivery locally.
ipchains by default denies email originating locally
(or something:  I'm no expert on ipchains or networks.
Quite the opposite).  I tried turning it off by moving
everything related to ip chains out of my rc*.d directories
and into rc*.comment directories, and rebooting.  Surprise!
the ipchains still default to deny.  I can get rid of all
the rules and set the defaults to ACCEPT with ipchains,
but it doesn't persist after reboots.  (It's not like I'm
on the internet any time other than when I'm downloading
mail, and my modem is 14.4K, and the isp assigns
me a different isp each time I dial in.)

3)  named doesn't seem to resolve even the localhost's
name any more.  Maybe that's related to the ipchains.
$ nslookup seal
*** Can't find server name for address No
     response from server
(finds a server at my isp, who not surprisingly doesn't
know about my own hosts name (i'm in the middle of
downloading mail as I write this))

$ ps ax | grep named
(doesn't find any named process - and I didn't kill any
And there _is_ an /etc/rc2.d entry of S19bind

I just don't get it.

4) xdm won't let me log in (neither root nor me)
I imagine this problem will go away when I get the above
solved.  I've moved xdm out of the rc*.d directories too.

5)  gpm keeps starting up and writing piles of junk
in my logs.  I keep killing it off and it keeps
coming back.  At least this one went away when
I took out the gpm stuff from my init directories.

6)  while I was in the init directories I saw stuff
related to tamagotchi.  What is tamagotchi, tamad, tama?
It doesn't exist in any of my man files (but that's not
surprising, it's surprisingly difficult to get _all_
the man pages installed) nor in `ls -lad /usr/doc/tama*`.


If I'm lucky, I'll be able to hack this machine so I'll be
able to read your answers later.  Sigh.

Hi! I'm a .signature virus! Copy me into your ~/.signature, please!

Reply to: