[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: openprom> whereis silo\n

On Tue, Oct 10, 2000 at 03:07:36PM -0400, Chad Miller wrote:
> Hi all.
> I got a spiffy E450 recently and am trying to use Potato on it.  I can
> install without problem (at openprom, 'boot cdrom').  It has several
> disks, and on the first I delete all partitions (including the ``Whole
> disk'') and remake them (Whole disk, root, swap).  I run the install
> gauntlet, and I follow the step that runs 'silo' at the end.
> Upon rebooting (my openprom 'boot-device' variable is set to 'disk'), the
> previous SunOS installation begins to boot!  I've deleted all other
> disks' partitions and ``Whole disk'' partitions (and created bare disks
> with one type-83 partition), and even 'dd if=/dev/zero of=/dev/hda' (from
> SunOS -- grrr).  I just tried at openprom 'boot disk0' and it boots SunOS.
> I don't want SunOS.  SunOS is ugly.  SunOS makes me itch.
> What must one do to boot SILO?  Ideas?

What is the SCSI ID of the Linux disk? Sounds like you are trying to boot
one that isn't SCSI ID 3 (the default that SPARC tries to boot). You'll
need to specify something like "boot disk2" or something. Then in linux,
edit /etc/silo.conf to put the boot block on the correct disk. The reason
it is done this way is to prevent from breaking installs where
Solaris/SunOS is on one disk, and Linux is on another (common setup).


/  Ben Collins  --  ...on that fantastic voyage...  --  Debian GNU/Linux   \
`  bcollins@debian.org  --  bcollins@openldap.org  --  bcollins@linux.com  '

Reply to: