[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

another floppy install report

I downloaded Eric's latest floppy images (2.1.8) today and reinstalled
using them. They worked with no problems this time: dbootstrap didn't
die once!

Unfortunately, I still can't boot from sd@0,0. Here's what I get on
the screen, in case it helps:

    Rebooting with command: disk3
    Boot device: /sbus/esp@0,800000/sd@0,0   File and args:
    Bad magic number in disk label
    Can't open disk label package
    Can't open boot device
    Type  help  for more information

Some other points:

Since gpm had the perfectly appropriate default "-t sun", should its
default values also include "-m /dev/sunmouse" instead of "-m
/dev/mouse"? I also found the responsiveness rather feeble: "-r 50"
works better for me.

I found that xserver-xsun worked, but only if I ran "startx" as root.
I fixed that by changing the permissions of /dev/fb[0-7] from 622 to
666. This might be another bug in makedev which Eric has to compensate
for when building boot-floppies ...

xserver-xsun24 worked too, but xserver-xsun-mono didn't work on my
hardware ...

I had to run mkfontdir by hand. I'm not sure if the package
installation scripts are supposed to take care of this.

There are some annoying and, I think, incorrect dependencies on xbase,
but I seem to recall that this is a known bug.

Delete key doesn't work in an Xterm.

I found that if I switched from VC 7 running X to VC 1 with
Ctrl-Alt-1, then back again with Alt-7, the X server believed the Ctrl
key still to be depressed. Most of the time, anyway. Not exactly a
major bug, but my XFCom_SiS running on i386 doesn't get confused in
this way.

Another very minor one: The question "Do you want to make the ... X
server the default? (y/n)", asked when you install an X server, is a
bit messed up on the screen; there's a newline missing in

It's probably a problem with my display, but I find the virtual
consoles almost unreadable until I do echo -e '\033[1m'. Xterms are
all right.

All in all, I found this distribution to be a lot more mature than
Debian's web pages suggest. Debian 2.1, running on four different
architectures, is going to be a excellent system ...


Reply to: